Bug 190886 - kyum destroys livna repos.
kyum destroys livna repos.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kyum (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 18:44 EDT by Aaron Konstam
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-03 16:20:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Konstam 2006-05-05 18:44:39 EDT
Description of problem:When you start kyum and then click the repository box for
the livan repos. All the livan repos are destoyed by their baseurl entries
being removed. Clicking livna-devel.repo destroys it. Clicking livna.repo seems
to destroy all the livna repos. 


Version-Release number of selected component (if applicable):
0.7.5-3

How reproducible:every time


Steps to Reproduce:
1.run kyum
2. Click on repositories tab
3. Click on the livna box.
2.
3.
  
Actual results: baseurls of livna.rep dissappear


Expected results: livna repo enabled or disabled


Additional info: A brief terst seemed to result in the livna repos are 
the only ones distroyed
Comment 1 Aaron Konstam 2006-05-06 15:35:25 EDT
The reason this is happening seesm to be as follows. In other repos when more
than one basrurl is wanted a mirrorlist is referred to. In the livna repos the
baseurls are listed one after another separated by a carriage return.

Well it looks like kyum will not acdcespt that format and it removes everything
after the first carriage return. Seems to me this would be possible to fix with
a change in the osurce code and a recompile.
Comment 2 Paul Howarth 2006-05-11 17:34:25 EDT
This bug is also noted in the upstream bug tracker:

http://sourceforge.net/tracker/index.php?func=detail&aid=1362350&group_id=144215&atid=757997
Comment 3 Aaron Konstam 2006-05-13 14:57:12 EDT
In the bug listed above the creater on kyum says htis is not abig sice kyum
handles repos differently than yum or yumex. And he does not have time to fix it.

Well since he is a voluteer I can't force him to fix it. However, the format of
yum repos is a given. His excuse for saying this is not a bug is just plain
unaxxeptable
Comment 4 Jochen Schmitt 2006-05-14 15:13:03 EDT
This bug is known as Bug #1362350 on sf.net
Comment 5 Jochen Schmitt 2006-07-04 15:08:29 EDT
I hava add the bug #1084 on bugzilla.livna.org to suggest the use of a
mirrorlist tag instead of multiple URL in a BaseURL tag.
Comment 6 Aaron Konstam 2006-07-04 16:24:50 EDT
This is a strange solution to the problem. Livna is using a valid form for their
repo . It is kyum that insists on not accepting this valid repo format. So the
solution is to have livna change its repo form. If they will do that fine. But
really the problem is with kyum not livna, So it is kyum that should be fixed.
But again we can't force anyone to do osmething they don't want to do. And we
say GPL software don't cause problems.
Comment 7 Dams 2006-07-05 06:25:20 EDT
I agree with comment #6. Our policy mirror so far has been to use main server
first (which has a 1Gbit/s ethernet link and peering connectivity with a bunch
of major French ISPs) and use mirrors as back up. The mirrorlist is commented in
the repo file and can be enabled at will.
Comment 8 Jochen Schmitt 2006-09-03 16:20:36 EDT
Becouse this is a problem which should solve by the upstream author, I have
closed this bug.

Note You need to log in before you can comment on or make changes to this bug.