Bug 190889 - gcl is not CLtL1 compliant, it is ANSI
gcl is not CLtL1 compliant, it is ANSI
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gcl (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 19:57 EDT by Perry Wagle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-03 15:14:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Perry Wagle 2006-05-05 19:57:24 EDT
Description of problem:
ACL2 won't build, needs CLtL1 compliance.  This GCL, despite its RPM/YUM
description saying it's CLtL1, is NOT CLtL1 compliant.

We probably need two variants, one ANSI, one CLtL1.

Also, the spelling of the --enable-readline option in the ./configure line in
the .spec file is misspelled as --enable-readine.  Also is mispelled in the
documentation of ./configure options.

Version-Release number of selected component (if applicable):
gcl-2.6.7-10.fc5

How reproducible:
ACL2 just won't build due to errors.

Steps to Reproduce:
1.  Try to build ACL2
2.  Watch the build fail almost immediately
  
Actual results:
ACL2 won't build

Expected results:
ACL2 builds

Additional info:
ACL2 requires a CLtL1 compliant common lisp to build.
When ./configure'd with --enable-ansi, it is ANSI, not CLtL1.
When ./configure'd with --disable-ansi, it is CLtL1 (tested, ACL2 builds fine.)

While you are modifying the line in the RPM .spec file, please fix the spelling
of --enable-readline (the actual option is spelled correctly, the documentation
is misspelled):

< %configure --enable-readine --enable-ansi --enable-tclconfig=%{_libdir}
--enable-tkconfig=%{_libdir}
---
> %configure --enable-readline --disable-ansi --enable-tclconfig=%{_libdir}
--enable-tkconfig=%{_libdir}

Thanks!
Comment 1 Gérard Milmeister 2006-05-06 06:02:10 EDT
I will fix the summary string to say ANSI instead of CLtL1.
You are correct about read(l)ine, I will fix that too, however
even currently it builds with readline.

However I will only build the ANSI version, not the CLtL1 one.
I successfully build ACL2 with CLISP, so you should use that one.

Note You need to log in before you can comment on or make changes to this bug.