Bug 190898 - X server problem on EPIA
X server problem on EPIA
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 22:11 EDT by Willis Gregory
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 17:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Willis Gregory 2006-05-05 22:11:10 EDT
Description of problem:

In January of this year, I installed Fedora 4 on a Via EPIA-ML. It has been
working like a champ. So good that I decided to purchase an identical system
(EPIA-ML motherboard and Morex case).

However, each time I tried installing the same Fedora 4 disks on the new system,
the graphics would go bonkers. At first I thought it was the motherboard, but 
when I installed Novell Linux Desktop 9, it installed and ran fine.

I then downloaded Fedora 5 and tried installing it. Same problem. When it gets
to the point that it attempts to start native X server, the screen disappears.

Note:  I am using a Belkin Omni Cube 4-port to allow use of the same CRT,
keyboard and mouse on 4 different systems.  I tried hooking the
CRT/mouse/keyboard directly into the system when trying to install Fedora 4;
however, I did not to this when I was trying to install Fedora 5.

When I used a text based install for Fedora 5, it worked ok, but as soon as I
logged in and invoked startx, the screen went (and stayed) blank. I then
installed Suse 9.2 and it worked fine.

When I looked at the BIOS settings on my new EPIA, the BIOS under Advanced
Chipset Features, Select Display Device, was set to: CRT+LCD. When I changed it
to CRT (same as my working EPIA), Fedora 5 loaded using graphic display with no
problem.

Since the Suse and Novell were able to load successfully with the CRT+LCD
setting, it sounds like a bug in Fedora.  

Version-Release number of selected component (if applicable):

Current Fedora 5 download ISOs

How reproducible:

Try installing Fedora on a EPIA with the BIOS set to CRT+LCD

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2006-07-21 15:55:49 EDT
Please try FC6 test 2 and let us know if you are still seeing problems with
this.  A lot of work has gone into X configuration recently so chances are
things should be better for you.
Comment 2 Red Hat Bugzilla 2007-06-11 23:10:41 EDT
requested by Jams Antill

Note You need to log in before you can comment on or make changes to this bug.