Bug 190900 - OOo has crashed opening a 2.3 MB rtf file.
OOo has crashed opening a 2.3 MB rtf file.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 23:51 EDT by SR Prasad Pendyala
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 07:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the file I am not able to open. (2.25 MB, application/rtf)
2006-05-05 23:51 EDT, SR Prasad Pendyala
no flags Details

  None (edit)
Description SR Prasad Pendyala 2006-05-05 23:51:25 EDT
Description of problem:
I am not able to open a 2.3MB rtf file using openOffice. OOo has crashed. I have
tried this few times and got the same error.

Please let me know, if this is not the right place to post this error. Bellow is
the bug report generated by the system.

Video Driver is probably: i810
Desktop is: GNOME
libgcj version is: libgcj-4.1.0-3
kernel is: Linux 2.6.16-1.2096_FC5 #1 Wed Apr 19 05:14:36 EDT 2006 i686 i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.7.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x2195680: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e680
0x2195ec0: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eec0
0x16c420:  + 0x420 (__kernel_sigreturn + 0x0)
0xa236e3: /lib/libc.so.6 + 0x296e3 (abort + 0x103)
0x4cc3550: /usr/lib/libstdc++.so.6 + 0xb9550
(__gnu_cxx::__verbose_terminate_handler() + 0x150)
0x4cc0f75: /usr/lib/libstdc++.so.6 + 0xb6f75
0x4cc0fb2: /usr/lib/libstdc++.so.6 + 0xb6fb2
0x4cc10ea: /usr/lib/libstdc++.so.6 + 0xb70ea
0x14834c7: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x134c7
0x148394d: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x1394d
0x14873a5: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x173a5
0x1487878: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x17878
0x14799c6: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x99c6
0x14934b5: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x234b5
0x1492847: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x22847
0x149290f: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x2290f
0x7fc1249: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x27249
0x7fc0f3f: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26f3f
0x7fc0ff7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26ff7
0x7fc29de: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x289de
0x7fc0f3f: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26f3f
0x7fc0ff7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26ff7
0xec1202: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x8202
0xebf24b: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x624b
0x4256725: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xec725
0x4256c4c: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xecc4c
0x4257077: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xed077
0x41a86d1: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x3e6d1
0x43dc803: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x38803
(desktop::DispatchWatcher::executeDispatchRequests(_STL::vector<desktop::DispatchWatcher::DispatchRequest,
_STL::allocator<desktop::DispatchWatcher::DispatchRequest> > const&) + 0x102b)
0x43d41c2: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x301c2
(desktop::OfficeIPCThread::ExecuteCmdLineRequests(desktop::ProcessDocumentsRequest&)
+ 0x136)
0x43cd7d7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x297d7
(desktop::Desktop::OpenClients() + 0xdab)
0x43cd945: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x29945
(desktop::Desktop::OpenClients_Impl(void*) + 0x35)
0x43cd994: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x29994
(desktop::Desktop::LinkStubOpenClients_Impl(void*, void*) + 0x1a)
0x27762f6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x832f6
0x28c4c26: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d1c26
0xe606b6: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1e6b6
0xe843da: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x423da
(SalDisplay::DispatchInternalEvent() + 0x64)
0xe11a5a: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14a5a
0x78947a1: /usr/lib/libglib-2.0.so.0 + 0x237a1
0x789615d: /usr/lib/libglib-2.0.so.0 + 0x2515d (g_main_context_dispatch + 0x16d)
0x78993ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
0x7899955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe11901: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14901
0xe8521d: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4321d
(X11SalInstance::Yield(unsigned char) + 0x27)
0x277d866: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a866
(Application::Yield() + 0x48)
0x277d8ea: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a8ea
(Application::Execute() + 0x26)
0x43cc0bb: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x280bb
(desktop::Desktop::Main() + 0x15af)
0x2781956: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e956
0x2781a09: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea09 (SVMain()
+ 0x2b)
0x43c4bf3: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20bf3 (sal_main
+ 0x57)
0x43c4c3f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20c3f (main + 0x27)
0xa0f7e4: /lib/libc.so.6 + 0x157e4 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4d1
Comment 1 SR Prasad Pendyala 2006-05-05 23:51:30 EDT
Created attachment 128684 [details]
This is the file I am not able to open.
Comment 2 Tomas Mraz 2006-05-09 02:48:58 EDT
You should have reported it agains openoffice.org and not a cs_CZ dictionary for it.
Comment 3 Caolan McNamara 2006-05-09 10:53:42 EDT
I am able to open this, can you still reproduce this problem with 2.0.2-5.9.2 as
for fc5-updates ?
Comment 4 SR Prasad Pendyala 2006-05-09 11:19:16 EDT
Hi,

Thanks for the quick response. 

I have now only realized that I am not able to open the open office itself in my
PC. How can I upgrade to '2.0.2-5.7.2'. Can you help me to provide the yum url
for upgrading this.

Regards,
Prasad.
Comment 5 SR Prasad Pendyala 2006-05-09 11:21:07 EDT
Sorry sorry, Please ignore the previous mail.

How can I upgrade to '2.0.2-5.9.2'? Can you help me to provide the yum url
for upgrading this.
Comment 6 Caolan McNamara 2006-05-10 07:43:55 EDT
It's a normal official fc5 update, so just 

> yum update openoffice.org-core 

should work. i.e. that /etc/yum.repos.d/fedora-updates.repo has "enabled" set to
true, which is the default IIRC
Comment 7 SR Prasad Pendyala 2006-05-10 20:37:22 EDT
Thanks. I am able to open after updating to 5.9.2.

Regards,
Prasad

Note You need to log in before you can comment on or make changes to this bug.