Bug 190912 - Failed to initialize dom0 state: No such device
Failed to initialize dom0 state: No such device
Status: CLOSED DUPLICATE of bug 190899
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 07:30 EDT by Steve Hill
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 16:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2006-05-06 07:30:32 EDT
Description of problem:
Xen doesn't work at all - xenstored shows:
FATAL: Failed to initialize dom0 state: No such device
full talloc report on 'null_context' (total 56 bytes in 3 blocks)
    struct domain                  contains     56 bytes in   2 blocks (ref 0)
        /local/domain/0                contains     16 bytes in   1 blocks (ref 0)
Because of this, xend doesn't correctly start.

Version-Release number of selected component (if applicable):
2.6.16-1.2111_FC5xen0

How reproducible:
Always

Steps to Reproduce:
1. Install and update FC5
2. Boot into the Xen0 kernel
3. Start xend
4. Execute "xm list"
  
Actual results:
"xm list" cannot connect to xend.

Expected results:
"xm list" should return the list of Xen domains as usual

Additional info:
An strace of xenstored shows:
open("/proc/xen/xsd_kva", O_RDWR)       = 10
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_SHARED, 10, 0) = -1 ENODEV (No such
device)

Downgrading to the 2.6.16-1.2096_FC5xen0 kernel fixes the problem.
Comment 1 Brian Stein 2006-05-08 16:06:54 EDT

*** This bug has been marked as a duplicate of 190899 ***

Note You need to log in before you can comment on or make changes to this bug.