Bug 190915 - yum list format truncates version numbers
yum list format truncates version numbers
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 08:26 EDT by Ed Hill
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 13:35:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a simple patch to keep from truncating version information in simpleList (562 bytes, patch)
2006-05-06 10:12 EDT, Ed Hill
no flags Details | Diff

  None (edit)
Description Ed Hill 2006-05-06 08:26:39 EDT
Description of problem:
The output from "yum list" truncates version numbers and there 
does not appear to be any way (short of perhaps writing a yum 
plugin) to change the output format.

Version-Release number of selected component (if applicable):
yum-2.6.1-0.fc5

How reproducible:
every time

Steps to Reproduce:
1. run "yum list 'kmod*'"
2. notice that version numbers in output are truncated

  
Actual results:
Version numbers are truncated and heres an example:

  kmod-madwifi.i686              0.0.0.20060317-3.2.6.1 livna

Notice how its impossible to tell *which* kernel version this particular 
kmod package corresponds to since the critical parts of the version 
information have been cut off.  Bad, bad!

Expected results:
Output formatting should preserve the full version information.
Acceptable solutions include increasing the width of the output.
Comment 1 Ed Hill 2006-05-06 10:12:54 EDT
Created attachment 128694 [details]
a simple patch to keep from truncating version information in simpleList
Comment 2 Ed Hill 2006-06-27 22:08:46 EDT
Hi folks, any news here?
Comment 3 Jeremy Katz 2006-09-18 16:35:26 EDT
The problem with this is that it then "overflows" a standard terminal :/
Comment 4 Jeremy Katz 2007-04-25 13:35:17 EDT
Breaking the terminal output isn't really an option.. and there's no good wya to
find out the width we can go to without using something like curses (... which
we really don't want to do)

Note You need to log in before you can comment on or make changes to this bug.