Bug 190919 - tickadj unable to set lower than 9000, ntp unable to correct time
tickadj unable to set lower than 9000, ntp unable to correct time
Status: CLOSED DUPLICATE of bug 165826
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 11:44 EDT by John
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 05:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John 2006-05-06 11:44:30 EDT
Description of problem:


Version-Release number of selected component (if applicable): Latest RH Ent Kernel


How reproducible:

Steps to Reproduce:
1. Run on Opteron dualcore
2. Set up and run ntpd
3. Watch time drift(quickly)
  
Time advances very quickly, would need to set a lower tick rate.

Additional info:
tickadj does not work as described in manual.
tickadj will not accept a lower value than 9000.
Comment 1 John 2006-05-06 18:05:53 EDT
This appears to have an underlying problem because of the limits in adjtimex.

On the system it's running on the hardware clock is so fast that the adjustment
level is exceeded causing no way to keep time correct.
Comment 2 Miroslav Lichvar 2006-05-09 04:51:36 EDT
This is probably a hw/kernel issue. Can you take a look at bug 165826? There are
a few things you can try.
Comment 3 John 2006-05-09 05:07:58 EDT
Thanks Miroslav

Adding 'clock=pmtimer' to the kernel options line in grub.conf has for the most
part fixed this issue.

I still have a couple of probs with ntpd dieing but now it can at least keep
time accurate while it's running.
Comment 4 Miroslav Lichvar 2006-05-09 05:40:35 EDT

*** This bug has been marked as a duplicate of 165826 ***

Note You need to log in before you can comment on or make changes to this bug.