Bug 190925 - Sound-juicer is not creating valid .ogg files: EOS not set
Sound-juicer is not creating valid .ogg files: EOS not set
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Monty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 13:38 EDT by Ian Malone
Modified: 2013-10-20 18:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-11 10:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 337026 None None None Never

  None (edit)
Description Ian Malone 2006-05-06 13:38:59 EDT
Description of problem:
Sound-juicer is not creating valid .ogg files: end of stream is
not being set.

Version-Release number of selected component (if applicable):
sound-juicer-2.14.3-1.fc5.1

(gstreamer-0.10.4-1
gstreamer-plugins-good-0.10.2-1
gstreamer-plugins-base-0.10.5-1
libogg-1.1.3-1.2
libvorbis-1.1.2-1.2)

How reproducible:
very

Steps to Reproduce:
1. Insert audio CD
2. Load sound-juicer
3. Select Edit | Preferences | Output Format | CD Quality, Lossy
4. Extract
5. Run ogginfo on one of the output files,

  
Actual results:
Observe "Warning: EOS not set on stream 1" error.

Expected results:
No error

Additional info:
This previously worked (I have several CDs ripped since
upgrading to FC5 with no problem).  Reverting to 2.14.0
(FC5 release version) does not solve the problem, so it
seems to be a dependency.
Comment 1 David Fletcher 2006-05-07 18:20:12 EDT
I can confirm this bug.

I just ripped a track and get the same warning message. The ogg file seems to
play OK in xmms but obviously the warning message should not be there.

Running ogginfo on a file that was ripped from the same track of the same CD
when I was using FC3 produces no warning messages.
Comment 2 John Thacker 2006-05-11 10:04:07 EDT
The problem's in gstreamer-plugins-base.
See upstream GNOME bug 337026:

http://bugzilla.gnome.org/show_bug.cgi?id=337026

It's unlikely to get fixed by Fedora, so this is really an upstream
bug.  Luckily, it's not absolutely terrible (and is fixable, by things
like vorbiscomment, according to the upstream bug.)

Note You need to log in before you can comment on or make changes to this bug.