Bug 190928 - seahorse cannot sign keys
seahorse cannot sign keys
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: seahorse (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 16:38 EDT by Piergiorgio Sartor
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 00:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2006-05-06 16:38:34 EDT
Description of problem:
Signing keys does not work.

Version-Release number of selected component (if applicable):
0.8-1.fc4

How reproducible:
Always.

Steps to Reproduce:
1.
Try to sign a key.

Actual results:
Depending on how seahorse is launched.
From menu, nothing happens.
From shell, an requester with error is opened and the following print
occur (in the shell terminal):

** (seahorse:5772): CRITICAL **: file seahorse-key-op.c: line 360
(sign_transit): should not be reached

** (seahorse:5772): CRITICAL **: edit_key: assertion `GPG_IS_OK (err)' failed

Expected results:
The key should be signed.

Additional info:
First of all, it seems there is a different behaviour depending
on how seahorse is launched: from shell it is more "verbose" and
it reports the error in a better way.

Second, this seems to be an incompatibillity of version 0.8 with
gpg 1.4.2, fixed in version 0.8.1, so upgrading should be enough.
Comment 1 Seth Vidal 2006-08-14 00:42:43 EDT
see if this is okay in FC-4, now.

I just put 0.8.1 through the build system.
Comment 2 Piergiorgio Sartor 2006-08-14 14:04:59 EDT
(In reply to comment #1)
> see if this is okay in FC-4, now.
> 
> I just put 0.8.1 through the build system.

Ops, I updated all the machine to FC5, so I cannot test it for FC4.
In any case, a seahorse 8.1 will be welcome also for FC5.

Thanks.
Comment 3 Seth Vidal 2006-08-14 15:32:51 EDT
0.8.1 should be available in FC5 shortly.

just waiting on the next extras push.

Note You need to log in before you can comment on or make changes to this bug.