Bug 19093 - ftp cds/stats every fs in /etc/fstab
Summary: ftp cds/stats every fs in /etc/fstab
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-14 01:10 UTC by Michael McConachie
Modified: 2013-09-02 05:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 22:03:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael McConachie 2000-10-14 01:10:49 UTC
strace shows that when ftp is started that it opens /etc/fstab then cds to
every entry including (/mnt/cdrom and /mnt/floppy).  This in turn causes
autofs to mount any nfsmounts in /mnt.

This happens for both anonymous users and regular users every time there is
a login.

I'll accept that there's a reason for ftp to be doing this, but we're
mighty curious about the reason.  :)

Comment 1 Jeff Johnson 2000-10-16 05:38:49 UTC
Um, perhaps you mean wu-ftpd. Changing component...

Comment 2 Bernhard Rosenkraenzer 2000-10-16 09:21:44 UTC
This most definitely doesn't happen here.
Which type(s) of authentication are you using? Are your users' home directories on NFS?

Comment 3 Bernhard Rosenkraenzer 2000-10-24 10:45:57 UTC
Closing due to lack of user input

Comment 4 Isaiah Weiner 2000-12-13 22:38:14 UTC
This should be reopened.  It's irritating to wait for CD, hard disk, and network
mounts to initialize.  A demonstration of the bug can definitely be arranged.

Comment 5 WU-FTPD Development Group 2001-03-12 22:03:21 UTC
Must be something else he's doing.

Non-duplicatable.  Close this ticket.


Note You need to log in before you can comment on or make changes to this bug.