Bug 1909413 - python-twisted fails to build: No package found for: (python3dist(h2) >= 3 with python3dist(h2) < 4)
Summary: python-twisted fails to build: No package found for: (python3dist(h2) >= 3 w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-twisted
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-19 19:03 UTC by Miro Hrončok
Modified: 2021-01-21 21:32 UTC (History)
4 users (show)

Fixed In Version: python-twisted-20.3.0-4.fc34 python-twisted-20.3.0-4.eln108
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-20 08:12:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-12-19 19:03:46 UTC
Description of problem:
Package python-twisted fails to build from source in Fedora rawhide due to a dependency issue:

No package found for: (python3dist(h2) >= 3 with python3dist(h2) < 4)

This is caused by the following update:

https://src.fedoraproject.org/rpms/python-h2/c/61241e71c529b751418aed978bc6695d710812aa?branch=master

Version-Release number of selected component (if applicable):
20.3.0-3.fc33

Steps to Reproduce:
fedpkg build

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-twisted

Upstream has this version guarded as < 4, presumably as precaution, see the latest update:
https://github.com/twisted/twisted/pull/755

Comment 1 Fedora Update System 2020-12-20 08:12:36 UTC
FEDORA-2020-e24c95882d has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 2 Fedora Update System 2021-01-21 21:32:12 UTC
FEDORA-2021-0a42876743 has been pushed to the Fedora ELN stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.