Bug 190944 - Xend fails to start under kernel-xen0-2.6.16-1.2111_FC5
Xend fails to start under kernel-xen0-2.6.16-1.2111_FC5
Status: CLOSED DUPLICATE of bug 190899
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 20:08 EDT by Steve Snodgrass
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-07 10:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snodgrass 2006-05-06 20:08:28 EDT
Description of problem: The xend service fails to start after upgrading to
kernel-xen0-2.6.16-1.2111_FC5.  It starts correctly if I reboot to
kernel-xen0-2.6.16-1.2096_FC5.  Xend.log contains the following:

[2006-05-06 18:09:58 xend] INFO (SrvDaemon:285) Xend Daemon started
[2006-05-06 18:09:58 xend] INFO (SrvDaemon:289) Xend changeset: unavailable .
[2006-05-06 18:09:58 xend] ERROR (SrvDaemon:299) Exception starting xend ((111,
'Connection refused'))
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line
293, in run
    servers = SrvServer.create()
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvServer.py", line
106, in create
    root.putChild('xend', SrvRoot())
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvRoot.py", line 40,
in __init__
    self.get(name)
  File "/usr/lib/python2.4/site-packages/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/usr/lib/python2.4/site-packages/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
39, in __init__
    self.xd = XendDomain.instance()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 550, in
instance
    inst.init()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 70, in init
    xstransact.Mkdir(VMROOT)
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
317, in Mkdir
    complete(path, lambda t: t.mkdir(*args))
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
323, in complete
    t = xstransact(path)
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
20, in __init__
    self.transaction = xshandle().transaction_start()
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line 18,
in xshandle
    xs_handle = xen.lowlevel.xs.xs()
RuntimeError: (111, 'Connection refused')

Version-Release number of selected component (if applicable): 2.6.16-1.2111_FC5


How reproducible: Always


Steps to Reproduce:
1. Upgrade to kernel-xen0-2.6.16-1.2111_FC5
2. Reboot
3.
  
Actual results: Xend fails to start


Expected results: Xend starts successfully


Additional info:
Comment 1 Steve Snodgrass 2006-05-07 10:26:02 EDT
Oops, looks like I duplicated bug #190899, though I swear I did a search first.  :-)

*** This bug has been marked as a duplicate of 190899 ***

Note You need to log in before you can comment on or make changes to this bug.