Bug 190959 - launchmail may open Evolution Contacts or Tasks instead
launchmail may open Evolution Contacts or Tasks instead
Status: CLOSED DUPLICATE of bug 197868
Product: Fedora
Classification: Fedora
Component: htmlview (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 06:14 EDT by Stuart Ellis
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 12:28:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Ellis 2006-05-07 06:14:12 EDT
Description of problem:

The launchmail script opens the last used Evolution component, which may have
been Contacts or Tasks, rather than the Email interface. The default desktop
panel icon for email uses launchmail, and so users that open their Email in this
way sometimes get the Contacts or Tasks instead.

I think that the issue is that the launchmail script fetches the string
"evolution" from the GConf key for mailto:, but Evolution nows requires
"evolution --component=mail" to force loading the Email interface, rather than
the defaulting to the last opened component.


Version-Release number of selected component (if applicable):

htmlview-3.0.0-14

How reproducible:


Steps to Reproduce:
1. Select Applications > Office > Contacts
2. Close Contacts
3. Click the Email panel icon, or run launchmail from a terminal window 
  
Actual results:

Launchmail opens the "Contacts" interface.

Expected results:

Launchmail ought to open the "Email" interface.


Additional info:
Comment 1 Warren Togami 2006-05-08 11:10:16 EDT
What happens if you click on a "mailto:" link?
Comment 2 Stuart Ellis 2006-05-08 15:35:34 EDT
Clicking a mailto: link in (the default Fedora) Firefox pops up both a "Compose
Message" window, and the last opened Evolution component as well.
Comment 3 Warren Togami 2006-05-08 16:14:27 EDT
Has this behavior began in FC5, or has FC4 behaved like this?

I suspect that this really is just a poor design problem of evolution.  None of
the other clients behave this way.  We'll see what the evolution maintainer &
project thinks.
Comment 4 Stuart Ellis 2006-05-08 16:54:06 EDT
From memory, I beleive that FC4 did the same thing.
Comment 5 Matthew Barnes 2006-07-26 12:12:24 EDT
See also bug #197868.
Comment 6 Warren Togami 2006-07-26 12:28:51 EDT
Hmm, Bug #197868 seems to have the acutal problem and solution in other components.

*** This bug has been marked as a duplicate of 197868 ***

Note You need to log in before you can comment on or make changes to this bug.