Bug 190964 - f-spot 0.1.11
f-spot 0.1.11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 10:08 EDT by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-10 02:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2006-05-07 10:08:46 EDT
Description of problem:

f-spot 0.1.11 has been out a while and fixes bugs related to database corruption:

f-spot 0.1.11 - March 13 2006 - Old Guard
-----------------------------------------
- Much improved contrast function.
- Database opens existing databases regardless of the sqlite
  version.  b.g.o #333644 and b.x.c #77711
- Database tries to force the correct encoding on v2 databases.
- Import dialog is better about cleaning up after itself.
- Valid cameras are no longer discarded from the camera list. b.g.o
  #324752.
- Group selector handles empty groups. b.g.o #333745
- Many slideshow improvements.
- Fix the erratic open with menu behavior. b.g.o #332949
- Improve the tag menu behavior when adding tags.
- Add --debug and --uninstalled command line options.
- Fixed JPEG orientation when saving new versions.
- Added a general exception dialog.
- Manu many more bugfixes.


I built a 0.1.11 version using the 0.1.10 srpm and had to drop the two patches
which I think are included now. Everything seems to work. The security patch was
definately applied (patch asked if it should be reversed) and the database
version patch doesn't apply because the code seems to have changed quite a bit
and might not support sqlite2 anymore.
Comment 1 Thomas J. Baker 2006-05-07 11:20:03 EDT
I see that 0.1.11 is already in rawhide. I built it for fc5 and it seems to work
fine.
Comment 2 Christopher Aillon 2007-06-10 02:23:17 EDT
Sorry for letting this languish.  Looks like everything is in order, so closing.

Note You need to log in before you can comment on or make changes to this bug.