Bug 190972 - Assertion rpmte.c:589 ix < Count fails during glibc installation
Assertion rpmte.c:589 ix < Count fails during glibc installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 13:00 EDT by Petr Vandrovec
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 15:45:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpme.py - intended for header removal (522 bytes, text/plain)
2006-05-10 17:25 EDT, Paul Nasrat
no flags Details

  None (edit)
Description Petr Vandrovec 2006-05-07 13:00:09 EDT
Description of problem:

Attempts to install new glibc fail with rather suspicious rpm error:

[root@petr-lx rpm]# rpm -Uhv /var/cache/apt/archives/glibc_2.4.90-6_i686.rpm
rpm: rpmte.c:589: rpmteColorDS: Assertion `ix < Count' failed.
Aborted

Version-Release number of selected component (if applicable):

[root@petr-lx rpm]# rpm -qa rpm*
rpm-build-4.4.2-24
rpm-python-4.4.2-24
rpm-devel-4.4.2-24
rpm-libs-4.4.2-24
rpm-4.4.2-24
[root@petr-lx rpm]# rpm -qa glibc*
glibc-common-2.4.90-4
glibc-kernheaders-3.0-29
glibc-headers-2.4.90-4
glibc-devel-2.4.90-4
glibc-2.4.90-4

How reproducible:

Always...  I've run 'rpm --rebuilddb', but problem persists.  All other packages
can be upgraded, only glibc hits this assertion.

Steps to Reproduce:
1. Upgrade system regulary every day or two from RedHat 7.3 to current Fedora Devel.
2. Upgrade to glibc 2.4.90-4 on Saturday.
3. Observe you cannot upgrade to 2.4.90-6 on Sunday.
  
Actual results:

glibc-2.4.90-6 fails to install with RPM assertion.

Expected results:

glibc-2.4.90-6 installed, or reasonable error provided by rpm.

Additional info:

http://gnome.or.kr/irc/?day=2006.05.05 seems to talk about this assertion as
well.  Unfortunately it is in korean...
Comment 1 Paul Nasrat 2006-05-08 11:04:35 EDT
Does it occur if you do rpm --test --justdb -e glibc

Comment 2 Paul Nasrat 2006-05-08 11:11:15 EDT
OK what is happening is that rpm 4.4.2-23 enabled header exhibiting the bug to
be installed, rpm 4.4.2-24 fixes rpm build correctly but when we update rpm-libs
we've got a buggy header installed so the assertion gets triggered on removal of
the glibc header.

Downgrading rpm-libs, updating glibc, reupdate rpm-libs should work around. 
Comment 3 Petr Vandrovec 2006-05-08 12:12:31 EDT
"rpm --test --justdb -e glibc" failed as well.  But your workaround with
downgrading rpm-libs worked, thanks.  For me bug can be closed as won't fix,
unless you are going to improve upgrade path for other users hit by this.
Comment 4 Paul Nasrat 2006-05-08 15:45:50 EDT
Rawhide temporary breakage, closing - I'm hoping most people won't hit this.
Comment 5 Damian Wrobel 2006-05-10 16:07:26 EDT
To which version do I need to downgrade the rpm-libs?
I've just tried the rpm-libs-4.4.1-23, but it didn't work.
Is there another way to workaround this problem?
Comment 6 Paul Nasrat 2006-05-10 16:55:04 EDT
You can download http://people.redhat.com/pnasrat/rpme.py

1) backup rpmdb (tar up /var/lib/rpm)
2) edit rpme.py and change the name variable to be the package in question (glibc)
3) as root run python rpme.py
4) rebuild the indexes (verbose will give you output for progress monitoring)
5) yum upgrade glibc
Comment 7 Damian Wrobel 2006-05-10 17:16:50 EDT
Thanks in advance. The only problem is that aforementioned host seems to be down
or unreachable. Would it be possible to make an attachment of rpme.py?
 
Comment 8 Paul Nasrat 2006-05-10 17:25:00 EDT
Created attachment 128862 [details]
rpme.py - intended for header removal 

Oh I think you hit a maintenance window.
Comment 9 Maxim Britov 2006-05-19 05:28:37 EDT
Hi, where i can found rpm-libs-4.4.1-23 ?
Comment 10 Paul Nasrat 2006-05-19 15:45:44 EDT
Maxim just use the rpme.py linked to at http://people.redhat.com/pnasrat/rpme.py
with the instructions from Comment #6.

Note You need to log in before you can comment on or make changes to this bug.