Bug 1909725 - kernelshark's new version numbering is lower than previous packages, requires an epoch bump
Summary: kernelshark's new version numbering is lower than previous packages, requires...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernelshark
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Zamir SUN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-21 13:27 UTC by "FeRD" (Frank Dana)
Modified: 2021-01-18 01:33 UTC (History)
3 users (show)

Fixed In Version: kernelshark-1.2-2 kernelshark-1.2-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-18 01:33:42 UTC
Type: Bug


Attachments (Terms of Use)

Description "FeRD" (Frank Dana) 2020-12-21 13:27:51 UTC
Description of problem:
The latest kernelshark-1.2-1.fc33 package will not automatically install using dnf, because its version number is lower than the previous kernelshark-2.8.3-4.fc33 package. This blocks upgrades of the trace-cmd package to the latest 2.9.1-4.fc33 builds, because kernelshark-2.8.3-4.fc33 requires trace-cmd-2.8.3-4.fc33.

Version-Release number of selected component (if applicable):
kernelshark-1.2-1.fc33

How reproducible:
100%

Steps to Reproduce:
1. dnf install kernelshark
2. dnf upgrade trace-cmd
3. dnf downgrade kernelshark-1.2-1.fc33

Actual results:
1: installs kernelshark-2.8.3-4.fc33
2: attempts to upgrade to trace-cmd-2.9.1, fails
3: succeeds, unblocks trace-cmd upgrade

Expected results:
'dnf install kernelshark' installs latest version automatically

Additional info:
kernelshark will need an Epoch bump to kernelshark-1:1.2-2.fc33, in order to receive install priority over kernelshark-2.8.3-4.fc33.

See also my bodhi comments:
https://bodhi.fedoraproject.org/updates/FEDORA-2020-e78d4f1508#comment-1784836
https://bodhi.fedoraproject.org/updates/FEDORA-2020-e78d4f1508#comment-1784837

Comment 1 Fedora Update System 2021-01-09 02:59:47 UTC
FEDORA-2021-4a6948ed0a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4a6948ed0a

Comment 2 Fedora Update System 2021-01-10 01:35:04 UTC
FEDORA-2021-4a6948ed0a has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4a6948ed0a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4a6948ed0a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2021-01-18 01:33:42 UTC
FEDORA-2021-4a6948ed0a has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.