Bug 190977 - Installation fails, Exception: device-mapper: reload ioctl failed: Invalid argument
Installation fails, Exception: device-mapper: reload ioctl failed: Invalid ar...
Status: CLOSED DUPLICATE of bug 409931
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 13:56 EDT by Gard Arneson Haugen
Modified: 2008-04-24 10:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dump to floppy after crash in installation (52.86 KB, text/plain)
2006-05-07 13:56 EDT, Gard Arneson Haugen
no flags Details

  None (edit)
Description Gard Arneson Haugen 2006-05-07 13:56:01 EDT
Created attachment 128714 [details]
Dump to floppy after crash in installation
Comment 1 Gard Arneson Haugen 2006-05-07 13:56:01 EDT
Description of problem:
Installation stops with this error after choosing installation language and the
keyboard language.
Fedora Core 4 is installed, so wanted results was to upgrade it to Core 5.

Version-Release number of selected component (if applicable):


How reproducible:
Every time, tried both the 386 DVD and x86_64 DVD.

Steps to Reproduce:
1.Install
2.Choose installation language
3.Choose keyboard language
  
Actual results:


Expected results:


Additional info:
Comment 2 Jeremy Katz 2006-05-07 16:46:48 EDT
Booting with 'linux nodmraid' may be a valid workaround.  But reassigning to
Peter to try to see the root cause 
Comment 3 Trevor Cordes 2006-10-30 02:19:58 EST
I just had anaconda hang on me, similar to but not exact to comment #1.  Mine
hung before the lang/kb options on blue screen.  Last message was loading
device-mapper ioctl.  Tried it with a Promise Fasttrack66 and a Syba SiI
IDE/PATA card in non-RAID mode (JBOD) and 2 drives.  I want to use these cards
as JBOD and let linux do the s/w md RAID1.

Adding nodmraid to the boot line worked as a workaround.  Thanks for that!

(FC3, my last install, never had this problem.)
Comment 4 Bug Zapper 2008-04-03 22:49:53 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Joel Andres Granados 2008-04-24 10:10:26 EDT
There is a bug where the dmraid stuff just blocks.  This bug has not been solved
yet and we are still working to fix it.   However there is a work around.  If
you use nodmraid, the installer will ignore/skip the dmraid stuff allowing the
install to finish.  This is a workaround and does not fix the problem.
There is a long list of bugs that are filed against this problem.  This bug is
one of them.  We have decided to close all the related nodmraid bugs and leave
just one open that will represent all of the others.  So this bug will be duped
for this reason.

*** This bug has been marked as a duplicate of 409931 ***

Note You need to log in before you can comment on or make changes to this bug.