Bug 190990 - Make ^- send ^_ instead of -
Make ^- send ^_ instead of -
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 18:05 EDT by Leszek Matok
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 17:19:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vte-0.12.1-ctrlminus.patch (530 bytes, patch)
2006-05-07 18:05 EDT, Leszek Matok
no flags Details | Diff

  None (edit)
Description Leszek Matok 2006-05-07 18:05:54 EDT
Description of problem:
^- (control-minus) inserts simple '-' to the terminal. I'm a joe user (and joe
uses ^_ for "undo") and this is the most annoying thing. I'm trying to convert
myself to gnome-terminal and I can't find any means to bind keys in it unlike
any terminal I used over the years, so I just patched vte to do what I want and
what Linux console does for years. If Linux console does something, it can't be
bad, right? :)

Please apply it, I won't even believe if you tell me someone or something
depends on ^- being just "-" :)

Version-Release number of selected component (if applicable):
Patch is against vte-0.12.1-1.fc5.1
Comment 1 Leszek Matok 2006-05-07 18:05:54 EDT
Created attachment 128718 [details]
vte-0.12.1-ctrlminus.patch
Comment 2 Hans de Goede 2006-08-04 13:14:39 EDT
Actually xterm does the same, since gnome-terminal emulates xterm I believe
gnome terminals behaviour is correct. I'm a joe user myself and I have always
used CTRL+SHIFT+- as undo.

Although I must admit this is a bit inconsistent with redo which is CTRL+SHIFT+6
(CTRL-^) where just CTRL+6 works too.
Comment 3 Leszek Matok 2007-10-02 17:19:29 EDT
Looks like it fixed itself. It's fixed in vte 0.16.9, but I don't know exactly
when it happened. Should I close it as fixed in CURRENTRELEASE or something?

Note You need to log in before you can comment on or make changes to this bug.