Bug 190999 - system-config-kickstart crashes with local core and updates repos
system-config-kickstart crashes with local core and updates repos
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 21:23 EDT by Ian Mortimer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 14:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2006-05-07 21:23:14 EDT
Description of problem:
system-config-kickstart crashes when retrieving package information from a
local repo.


Version-Release number of selected component (if applicable):
system-config-kickstart-2.6.10-1


How reproducible:
always


Steps to Reproduce:
1. Set up a local repo for core and updates - either http or nfs
2. Point fedora-core.repo and fedora-updates.repo at the local repo
3. Start system-config-kickstart
  
Actual results:
system-config-kickstart starts ok, the retrieving package information 
widget comes up, the progress bar gets about half way and then
crashes with python errors.

Expected results:
Should be able to get package information from the local repo since
yum can.


Additional info:

yum working fine for installs and updates.

Python error is:

Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 80,
in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 158, in __init__
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 143, in __init__
    self.y = sckYumBase(pbar)
  File "/usr/share/system-config-kickstart/packages.py", line 117, in __init__
    self.doRepoSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 256, in doRepoSetup
    repo.getRepoXML(text=repo)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 682, in getRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 629, in get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
yum.Errors.RepoError: failure: repodata/repomd.xml from core: [Errno 256] No
more mirrors to try.
Comment 1 Chris Lumens 2006-05-10 16:22:03 EDT
What do your enabled repo config files look like?
Comment 2 Ian Mortimer 2006-05-10 23:35:37 EDT
The only changes to yum.conf are:

   keepcache=1
   exclude=kernel*

The only enabled repos are:

   [core]
   name=Fedora Core $releasever - $basearch
   baseurl=http://fedora.our.net/$releasever/$basearch/Fedora/RPMS
   enabled=1
   gpgcheck=1
   gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

   [updates]
   name=Fedora Core $releasever - $basearch - Updates
   baseurl=http://fedora.our.net/updates/$releasever/$basearch
   enabled=1
   gpgcheck=1
   gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

There are other repos configured - local and remote - but they are all
disabled by default.  Remote repos require a proxy.

Just to be sure I removed all other repos so those were the only two.
system-config-kickstart still crashes at the same point.  I also tried
with just core but got the same result.


Thanks
--
Ian
Comment 3 Chris Lumens 2006-09-15 11:33:59 EDT
Is this better in FC6test3?  There have been a lot of yum updates since this bug
was originally filed and it's possible this has been fixed upstream.
Comment 4 Ian Mortimer 2006-09-17 19:36:29 EDT
Haven't had time to try any of the FC6 beta tests.  When FC6 is released 
I'll try with that and post the results here.
Comment 5 Ian Mortimer 2006-10-30 20:02:28 EST
Fails in the same way with FC6:

# system-config-kickstart

(system-config-kickstart.py:32445): libgnomevfs-WARNING **: Failed to open
session DBUS connection: Unable to determine the address of the message bus (try
'man dbus-launch' and 'man dbus-daemon' for help)
Volume monitoring will not work.
Loading "installonlyn" plugin
Cannot open logfile /tmp/tmpsn-r-V/var/log/yum.log
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 80,
in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 158, in __init__
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 143, in __init__
    self.y = sckYumBase(pbar)
  File "/usr/share/system-config-kickstart/packages.py", line 117, in __init__
    self.doRepoSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 299, in doRepoSetup
    repo.setup(self.conf.cache)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 526, in setup
    raise Errors.RepoError, ('Cannot open/read repomd.xml file for repository:
%s' % self)
yum.Errors.RepoError: Cannot open/read repomd.xml file for repository: core

yum updates and installs are working fine:

# ls /var/cache/yum/core
cachecookie  packages        primary.xml.gz.sqlite
headers      primary.xml.gz  repomd.xml

But:

# ls /tmp/tmpsn-r-V/var/cache/yum/core
headers  packages
Comment 6 Ian Mortimer 2006-11-01 20:35:39 EST
I found a solution.  Replaced $releasever in fedora-core.repo with the actual
version number and it's now working.

This fails:

   baseurl=http://our.fedora.server/$releasever/$basearch

This works:

   baseurl=http://fedora1.physics.uq.edu.au/6/$basearch


   
Comment 7 Scott Baker 2006-11-05 13:26:34 EST
I was just about to file this as a bug when I found this bug. I can confirm the
crash listed above. I can also confirm that the fix from comment #6 works for
me. Looks like system-config-kickstart just needs to be $releasever aware.
Comment 8 Chris Lumens 2006-11-08 11:10:16 EST
Strange, because the substitution of that variable should be handled by yum
itself.  I'll need to investigate if I'm actually calling the yum API correctly
for setup.
Comment 9 Scott Baker 2006-11-08 11:16:02 EST
I can confirm the following does *NOT* work:

baseurl=http://mirror.web-ster.com/fedora/core/$releasever/$basearch/os/

And this *does* work. Pretty simple fix.

baseurl=http://mirror.web-ster.com/fedora/core/6/$basearch/os/

Comment 10 Chris Lumens 2006-11-08 12:01:15 EST
Got it.  Thanks for everyone's help in debugging this, and sorry for how long it
took.  I will release an FC6 update to address this as well.
Comment 11 Fedora Update System 2006-11-09 11:55:28 EST
system-config-kickstart-2.6.17-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 12 Fedora Update System 2006-11-13 13:56:33 EST
system-config-kickstart-2.6.17-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.