Bug 191038 - Xend fails after Friday's update
Xend fails after Friday's update
Status: CLOSED DUPLICATE of bug 190899
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-08 07:53 EDT by John D. Ramsdell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 16:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John D. Ramsdell 2006-05-08 07:53:44 EDT
I did a yum update on Friday, and now xend fails to start.  I've had no problems
with Xen previously, and installed it using the instructions on the
virtualization project page.

[root@goo ramsdell]# /usr/sbin/xm list
Error: Error connecting to xend: Connection refused.  Is xend running?
[root@goo ramsdell]# /usr/sbin/xend start
ERROR: Could not obtain handle on privileged command interface (2 = No such file
or directory)
Traceback (most recent call last):
  File "/usr/sbin/xend", line 33, in ?
    from xen.xend.server import SrvDaemon
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line 21,
in ?
    import relocate
  File "/usr/lib/python2.4/site-packages/xen/xend/server/relocate.py", line 26, in ?
    from xen.xend import XendDomain
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 33, in ?
    import XendDomainInfo
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 37, in ?
    import image
  File "/usr/lib/python2.4/site-packages/xen/xend/image.py", line 31, in ?
    xc = xen.lowlevel.xc.xc()
RuntimeError: (9, 'Bad file descriptor')
[root@goo ramsdell]# cat /var/log/xend.log
[root@goo ramsdell]# uname -a
Linux goo 2.6.16-1.2111_FC5 #1 Thu May 4 21:16:58 EDT 2006 i686 i686 i386 GNU/Linux
[root@goo ramsdell]# /usr/sbin/xm list
Error: Error connecting to xend: Connection refused.  Is xend running?
[root@goo ramsdell]#
 
sh-2.05b$
Comment 1 John D. Ramsdell 2006-05-08 15:40:18 EDT
Opps.  I boot the wrong kernel when I generated the above message.  When the
right kernel is booted, I cannot CD to /var/run/xenstored.  Here is a corrected
transcript:

[ramsdell@goo ~]$ su -
Password:
[root@goo ~]# xm list
Error: Error connecting to xend: Connection refused.  Is xend running?
[root@goo ~]# rm /var/log/xend.log
rm: remove regular file `/var/log/xend.log'? y
[root@goo ~]# xend start
[root@goo ~]# cat /var/log/xend.log
[root@goo ~]# xm list
Error: Error connecting to xend: Connection refused.  Is xend running?
[root@goo ~]# cat /var/log/xend.log
[root@goo ~]# uname -a
Linux goo 2.6.16-1.2111_FC5xen0 #1 SMP Thu May 4 21:51:32 EDT 2006 i686 i686
i386 GNU/Linux
[root@goo ~]#
Comment 2 John D. Ramsdell 2006-05-08 15:46:03 EDT
Add... /var/run/xenstored is present, a xend restart produces output in
/var/log/xend.log:

sh-2.05b$ cat xend.log
[2006-05-08 15:49:59 xend] INFO (SrvDaemon:285) Xend Daemon started
[2006-05-08 15:49:59 xend] INFO (SrvDaemon:289) Xend changeset: unavailable .
[2006-05-08 15:49:59 xend] ERROR (SrvDaemon:299) Exception starting xend ((111,
'Connection refused'))
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line
293, in run
    servers = SrvServer.create()
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvServer.py", line
106, in create
    root.putChild('xend', SrvRoot())
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvRoot.py", line 40,
in __init__
    self.get(name)
  File "/usr/lib/python2.4/site-packages/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/usr/lib/python2.4/site-packages/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
39, in __init__
    self.xd = XendDomain.instance()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 550, in
instance
    inst.init()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 70, in init
    xstransact.Mkdir(VMROOT)
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
317, in Mkdir
    complete(path, lambda t: t.mkdir(*args))
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
323, in complete
    t = xstransact(path)
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
20, in __init__
    self.transaction = xshandle().transaction_start()
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line 18,
in xshandle
    xs_handle = xen.lowlevel.xs.xs()
RuntimeError: (111, 'Connection refused')
sh-2.05b$

Comment 3 Brian Stein 2006-05-08 16:02:51 EDT

*** This bug has been marked as a duplicate of 190899 ***

Note You need to log in before you can comment on or make changes to this bug.