Bug 19105 - unable to dual boot, Win98, even with Red Hat tech support
unable to dual boot, Win98, even with Red Hat tech support
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-14 09:21 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 19:08:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-14 09:21:04 EDT
Red Hat technical support person Will Clark advised me to file this here.
PIII 450 Mhz 13G drive 160M RAM Win98 Second Ed.
8.001M (hda1) for Win98, remainder for linux
After linux install, linux will boot, but enter 'dos' at lilo prompt, and machine displays:
"loading dos...", and then a blank cursor. Nothing else happens!
Even a Win98 boot disk will not then boot the machine to Windows.
The only way I can get Windows back:
/sbin/lilo -u; then (via install CD) fdisk and delete all linux partitions
At this point the machine will load a Win98 boot disk.
I then say "fdisk /mbr" and restart, and Win98 boots up as if nothing had happened.
Will Clark has called this "a strange strange problem" and advised this notification.
Thank you for your attention,
John Kelleher
johnkelleher@usa.net
Comment 1 Brock Organ 2000-10-17 19:08:11 EDT
I agree this is a strange problem ... here is something to try ... :)

does running LILO in your linux system post-install succeed (as in my example
below) or does it fail ... (just wondering if there was a LILO config problem
that was bad enough to keep LILO from working properly, but not bad enough to be
caught by the installer!)

SAMPLE LILO SUCCESSFUL RUN:

[root@foobar /root]# lilo -v
LILO version 21.4-4, Copyright (C) 1992-1998 Werner Almesberger
'lba32' extensions Copyright (C) 1999,2000 John Coffman

Reading boot sector from /dev/hda
Merging with /boot/boot.b
Mapping message file /boot/message
Boot image: /boot/vmlinuz-2.2.16-22
Added linux *
/boot/boot.0300 exists - no backup copy made.
Writing boot sector.
[root@foobar /root]# echo $?
0
[root@foobar /root]# 

(note the 0 exit code returned by the echo $?, that means lilo succeeded!)
Comment 2 Jeremy Katz 2002-06-04 01:19:35 EDT
Closing due to lack of activity

Note You need to log in before you can comment on or make changes to this bug.