Bug 191063 - selinux consideration in mailman installation instructions
selinux consideration in mailman installation instructions
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
Tommy Reynolds
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-08 12:44 EDT by Michael McAndrew
Modified: 2009-07-07 00:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 17:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael McAndrew 2006-05-08 12:44:45 EDT
Hi there,

I hope this is the right place to file this request to edit the file:
/usr/share/doc/mailman-2.1.7/INSTALL.REDHAT

I was following these instructions to  configure mailman.  On typing many of the
commands, I was presented with errors like this:

Traceback (most recent call last):
 File "bin/genaliases", line 116, in ?
   main()
 File "bin/genaliases", line 102, in main
   MTA.create(None, nolock=True, quiet=quiet)
 File "/usr/lib/mailman/Mailman/MTA/Postfix.py", line 232, in create
   _update_maps()
 File "/usr/lib/mailman/Mailman/MTA/Postfix.py", line 53, in _update_maps
   raise RuntimeError, msg % (acmd, status, errstr)
RuntimeError: command failed: /usr/sbin/postalias /etc/mailman/aliases
(status: 1, Operation not permitted).

I was running in SELinux Enforcing mode.  It turns out that these problems don't
happen if you are in Permissive mode.

Is it worth pointing this out in that peice of documentation?  I think it would
help.

Thanks,
Michael
Comment 1 John Villalovos 2007-05-23 01:15:49 EDT
This might be a duplicate of #234773
Comment 2 John Villalovos 2007-05-23 01:55:20 EDT
(In reply to comment #1)
> This might be a duplicate of #234773

I meant to say, this seems like a duplicate of Bug 234773
Comment 3 Karsten Wade 2007-05-24 06:01:03 EDT
Not really a duplicate, per se, although it does appear that the errors
encountered were because of the lack of appropriate policy.

The document at /usr/share/doc/mailman* is owned by the mailman package.  So, at
the least, this bug report would start there.  However, it might really be
considered to be a bug in the upstream Mailman content.

If you feel this report is still appropriate for the mailman package, let's
move/reassign the bug over there.  If it is no longer a problem and/or the
content needs to be changed upstream in Mailman, we'll close this NOTABUG.
Comment 4 eric@christensenplace.us 2009-06-09 17:08:32 EDT
This does not appear to be a documentation issue.
Comment 5 eric@christensenplace.us 2009-07-07 00:09:39 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.