Bug 191087 - console=ttyX info not added to append line in elilo.conf
console=ttyX info not added to append line in elilo.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-08 15:01 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 09:36:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-05-08 15:01:37 EDT
Description of problem:
When I install the latest rawhide on some of my HP Integrity (ia64) servers I
need to specify console= so that it uses the correct serial port for the console.  

I specify this on the install boot but the elilo.conf file that is created does
not contain this.  On RHEL3+4 any info I had on the append line when I booted
was copied to the insalled elilo.conf

Version-Release number of selected component (if applicable):

anaconda-11.1.0.8-1

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-05-09 15:15:30 EDT
Were you doing a serial install?
Comment 2 Doug Chapman 2006-05-09 15:48:04 EDT
correct, serial install
Comment 3 Jeremy Katz 2006-05-09 16:23:18 EDT
Did you boot with 'linux serial console=...' or how did the serial console
device get discerned?
Comment 4 Doug Chapman 2006-05-09 17:03:32 EDT
when I do the install I boot with:

     linux console=ttyS1

and the install works fine.  In RHEL3 and RHEL4 this info would then be added to
the append line of elilo.conf but in rawhide it does not. 

Comment 5 Jeremy Katz 2006-05-09 17:20:21 EDT
Can you try with 'linux serial console=ttyS1' instead?  
Comment 6 Doug Chapman 2006-05-10 10:55:12 EDT
tried linux serial console=ttyS1 with the same results
Comment 7 Jeremy Katz 2006-05-15 14:29:37 EDT
Hmmm, the code looks okay from a quick inspection.  It'll require a deeper look
Comment 8 Aron Griffis 2006-08-16 22:21:32 EDT
Doug, this report is from May and rawhide has made some good progress on ia64 in
the meantime...  can you verify this problem still exists?
Comment 9 Doug Chapman 2006-08-17 09:36:08 EDT
I have verifed this one.  Sorry, should have closed it out some time ago.

Note You need to log in before you can comment on or make changes to this bug.