Bug 19109 - UK Keymap not working
Summary: UK Keymap not working
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-14 17:46 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-27 10:32:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-14 17:46:05 UTC
I selected a 105 Key international UK keyboard via the graphical 
installer, and tested it in the text entry box provided.  However, after 
installation, the delete key does not work - it produces a tilde (~) and a 
beep when pressed in the console window.

On logging out, the following (paraphrased) error can be seen in the text 
wind-down :

     Couldn't load XKB Keymap

Together with something about not being able to find symbol ""

Comment 1 Alan Cox 2000-10-14 21:45:03 UTC
Confirmed.

UK101 works correctly  UK105 does not.


Comment 2 Need Real Name 2000-10-15 12:09:42 UTC
Hi,

I have a similar problem with my Swedish keyboard (and noted one more at 
Bugzilla #18987).

First, I upgraded to RH 7.0 from RH 6.2 and my keys were OK, but then I noted 
and reported Bugzilla #18748 and eventually gave up as none of my attemps were 
any good.

So, I  re-installed RH 7.0 and now I cannot use Backspace, or any of the Alt-
keys to produce @, #, $, {, [, ], } or \. [I cannot even write my own e-mail!]


I have tried both "pc101" and "pc102" together with "se".

As this is the third report on a similar issue with non-US keyboards, there 
might be something general about it.

Meanwhile, is there something I can do to get a working keyboard. The effort of 
manually entering a keyboard table seems quite intimidating.

Cheers,

Rudy Mansgaten


Comment 3 Bill Nottingham 2000-10-16 16:40:55 UTC
Assigning to console-tools; that's where the keymaps are.

Comment 4 Bernhard Rosenkraenzer 2000-10-17 08:52:14 UTC
Assigning to XFree86 - since console-tools doesn't make a difference between
pc102 and pc105, this must be about X keymaps; those are in XFree86.

Comment 5 adam.huffman 2000-10-26 15:04:20 UTC
I have a similar problem. The pound sign comes out as e with a diaeresis and the
character 
set handling in mutt seems to be broken e.g. accented characters aren't shown
properly.

This is on a box upgraded from 6.2

Comment 6 Need Real Name 2000-11-09 13:08:34 UTC
I'm getting similar problems with the backspace key as well. I'm using a
workaround
that works for me at the moment and that is to use setxkbmap . 
This fixes the backspace problem and seems to leave all my other keys working ok
as well.

My XF86Config settings are.
     XkbModel    "pc101"
     XkbLayout   "gb"


Comment 7 Mike A. Harris 2001-04-09 05:51:49 UTC
Just a note to everyone who has contributed here..  Although many of you
are having perhaps similar problems, they are almost certainly solved in
a different manner.  In other words, each problem is related to keymaps,
however they are not related to the UK keymap that this bug report was
filed with.  As such, I request that each of you that has added info here
of similar problems, please file a new bugzilla report for your problem,
perhaps referencing this one if you like.  The reason is that once I solve
the UK keymap issue, this bug is fixed, and your bugs will get lost when the
bug is closed.

Comment 8 Mike A. Harris 2002-01-27 10:32:32 UTC
Is this problem still present in Red Hat Linux 7.2 with XFree86-4.1.0?

Comment 9 Mike A. Harris 2002-03-16 15:42:42 UTC
Closing bug assuming it is fixed in the XFree86 4.1.0-15 erratum that
is available for RHL 7.1 and 7.2, or in rawhide.

If it is still an issue, be sure to try both of these releases and
reopen the bug report if necessary.  I do not have this keyboard, and
nothing obvious stands out at me when looking at the keymap files.

If the problem persists, if someone could do some debugging with xev
et al. it might help find a solution.


Note You need to log in before you can comment on or make changes to this bug.