Bug 1911043 - Kernel 5.10 fails to boot past luks decryption on Amd Apu A9
Summary: Kernel 5.10 fails to boot past luks decryption on Amd Apu A9
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 33
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-27 09:47 UTC by Ryan
Modified: 2021-01-08 07:36 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-08 07:36:52 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 210867 0 None None None 2020-12-27 09:47:18 UTC

Description Ryan 2020-12-27 09:47:18 UTC
1. Please describe the problem:

No display after initial boot splash and kernel selection when booting AMD laptop (Dell Inspiron 3180) on Kernel 5.10, does not boot past luks decryption request, even when disabling the frame buffer via kernel args or booting with kernel arg systemd.unit=multi-user.target.

2. What is the Version-Release number of the kernel:

5.10.2-200.fc33.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

has worked previously with kernels up to 5.9.16

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Install 5.10 kernel, reboot

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

yes (caveat, i used the f33 version from koji (5.10.0-98.fc33.x86_64) so I didn't have to install the rawhide version of glib as well. Note that selecting the rawhide version only gave me the option to upgrade kernel-tools and kernel-headers and was not going to upgrade the kernel at all (probably because I already had 5.10.3 installed even though I had booted into the 5.9.16 kernel).

6. Are you running any modules that not shipped with directly Fedora's kernel?:

no

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

you do not get a boot log when this crashes as the kernel only gets as far as the luks encryption.

Further information:

This does not affect my desktop PC. This is happening for other people on the internet (see external bug). This issue can be worked around with amdgpu.dc=0 as per:

https://www.kernel.org/doc/html/latest/gpu/amdgpu-dc.html

Without the workaround, you can't get past a blank screen and it doesn't respond to ctrl+alt+del which makes me think it's a full kernel panic.

Comment 1 Ryan 2020-12-27 09:48:52 UTC
CPU info:

smpboot: CPU0: AMD A9-9420e RADEON R5, 5 COMPUTE CORES 2C+3G (family: 0x15, model: 0x70, stepping: 0x0)

Comment 2 Ryan 2020-12-30 00:42:23 UTC
Still occurring with 5.10.3, although looking at the changelog there was no updates to the amdgpu handling so I expected no change.

Comment 3 Ryan 2021-01-02 00:08:33 UTC
still happening with 5.10.4

Comment 4 Scott Dodson 2021-01-04 16:10:31 UTC
This

Comment 5 Ryan 2021-01-08 04:48:10 UTC
issue is resolved for me in latest kernel 5.10.5-200.fc33.x86_64 currently in koji

Comment 6 Ryan 2021-01-08 07:36:52 UTC
closing this bug report, as issue is resolved for me as outlined above.


Note You need to log in before you can comment on or make changes to this bug.