Bug 191109 - Compiler bug causes detection loop in matroxfb_probe to fail
Summary: Compiler bug causes detection loop in matroxfb_probe to fail
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: 5
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-08 22:33 UTC by Ian Romanick
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 4.1.0-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 06:45:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 26643 None None None Never

Description Ian Romanick 2006-05-08 22:33:16 UTC
Description of problem:

matroxfb fails to detect GXT135P (PCI Matrox G450).

Version-Release number of selected component (if applicable):


How reproducible:

Try to load the matroxfb module on a PowerPC system with a GXT135P card installed.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I have submitted this bug against gcc4 because I have been told by various
people that the root problem is a compiler issue in GCC 4.1.0 and GCC 4.0.x.  I
inserted some debug messages in the detection loop in matroxfb_probe, and I was
able to convince myself that this is the case.

As far as I know, this GCC bug *only* affects PowerPC.

Comment 1 David Woodhouse 2006-05-08 22:42:30 UTC
Can you give a GCC PR#, or some more details of precisely where the
miscompilation is?

Comment 2 Jakub Jelinek 2006-05-09 06:45:11 UTC
Which means it is fixed in rawhide GCC and will show up in FC5 updates testing
within a week.


Note You need to log in before you can comment on or make changes to this bug.