Bug 1911364 - broken pipe errors installing kernel
Summary: broken pipe errors installing kernel
Keywords:
Status: CLOSED DUPLICATE of bug 1911038
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-28 23:26 UTC by Tom Horsley
Modified: 2021-01-15 14:00 UTC (History)
26 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 14:00:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Horsley 2020-12-28 23:26:35 UTC
1. Please describe the problem:
  Running scriptlet: kernel-core-5.9.16-200.fc33.x86_64                 341/341 
sort: fflush failed: 'standard output': Broken pipe
sort: write error

gzip: stdout: Broken pipe

gzip: stdout: Broken pipe
sort: write failed: 'standard output': Broken pipe
sort: write error


2. What is the Version-Release number of the kernel:
5.9.16-200.fc33.x86_64


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
Doing a dnf update for this kernel is the first time I've seen it.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Don't know, I'll try reinstall if I can boot and let you know.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Don't know

6. Are you running any modules that not shipped with directly Fedora's kernel?:
Nope

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.
I havend tried booting this kernel yet, so the logs won't say anything useful.

Comment 1 Tom Horsley 2020-12-28 23:30:34 UTC
Just rebooted and this new kernel was the default an seems to have booted just fine. I have no idea what all the alarming broken pipe stuff was about, but I see no problems it might have caused.

Comment 2 Tom Horsley 2020-12-30 01:52:21 UTC
Installed updates on a different system, got the same broken pipe messages. Looks like reproducible is 100%

Comment 3 JayJayJazz 2020-12-31 15:02:27 UTC
I had the same issue on my system. Some other people also report this on bodhi:
https://bodhi.fedoraproject.org/updates/FEDORA-2020-91a576dc0d

Comment 4 Thorsten Leemhuis 2021-01-05 04:35:57 UTC
TWIMC: I tried to track this down and it seems to be the problem occurs in dracut (which is indirectly called by the kernel's posttrans script) – but maybe it's not dracut fault.

See Bug 1911364 for details.

Comment 5 Thorsten Leemhuis 2021-01-05 04:36:56 UTC
(In reply to Thorsten Leemhuis from comment #4)
> See Bug 1911364 for details.

Sorry, typo: see Bug 1911038 for details.

Comment 6 Ryan 2021-01-08 07:24:26 UTC
has been happening in all versions of the 5.10 kernel up to 5.10.5

Comment 7 Thorsten Leemhuis 2021-01-15 07:48:40 UTC
There are new details in Bug 1911038 now; that's why I'd vote for marking this one as duplicate of that one, even if this one is the oldest (sorry for not finding it earlier).

Comment 8 Tom Horsley 2021-01-15 14:00:13 UTC
Seems reasonable to me. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 1911038 ***


Note You need to log in before you can comment on or make changes to this bug.