Bug 191145 - Yum Installation failed with bad configuration
Yum Installation failed with bad configuration
Product: Fedora
Classification: Fedora
Component: firestarter (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Damien Durand
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-05-09 01:48 EDT by Richard England
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-17 01:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard England 2006-05-09 01:48:11 EDT
Description of problem:
On my FC5 (32 bit) installation, I used yumex to install  Firestarter v 1.0.3
from the extras repo and got the latest version:


However, I was getting an error saying:

"A proper configuration for Firestarter was not found. If you are
running Firestarter from the directory you built it in, run 'make
install-data-local' to install a configuration, or simply 'make
install' to install the whole program.
Firestarter will now close."

Since Google told me that this was an issue going from 0.9.x versions to 1.0.x
versions and a fix was to remove the configuration files, I tried that but had
no luck. I tried more searches but could find nothing regarding this problem
with FC5.  I finally went to look at the repository to see if I could grab an
older version. I found the following, which I installed, (couldn't get any
worse, I figured).


This older version works.
Interesting is the fact that yumex does not now show an update being available,
now, as I would have expected, since I believe there was something like a month
between the releases. 

Version-Release number of selected component (if applicable):


How reproducible:
Used rpm -ev to remove what was installed and tried both yum and a straight rpm
install. Both failed in the same manner.

Additional info:
The system was a pristine system, prior to FC install, not even Windoze.  It was
loaded with FC4 and sat for 2 weeks then was "upgraded" (not reloaded) via CDs
to FC5.  Very little was done to it in FC4.  I'm pretty confident that
Firestarter was not installed in FC4.  When I went to install it after the
FC4/FC5 conversion, firstarter was grabbed from Extras.

After having success iwth 1.0.3-10.fc5 I investigated the 1.0.3-11.fc5  version.
When I tried  "yum update firestarter\* "  it installed the 1.0.3-11.fc5 version
and it appears to be working with no reconfiguration requirements.  It would
appear that my problem had something to do with the initialization but I tried
to change protections on directories and removing and reinstalling (2 times, as
indicate above) to no avail.
Comment 1 Ville Skyttä 2006-09-27 14:00:55 EDT
Reassign to current maintainer.

Note You need to log in before you can comment on or make changes to this bug.