Bug 191154 - "xulrunner" built with unsufficient extensions
"xulrunner" built with unsufficient extensions
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marco Pesenti Gritti
Depends On:
  Show dependency treegraph
Reported: 2006-05-09 05:53 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-09 10:42:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-05-09 05:53:10 EDT
Description of problem:
Building "epiphany" against "xulrunner" fails because the built-in
extensions of the latter are not sufficient. "configure" aborts with
the message: "configure: error: xulrunner needs to be compiled with
at least --enable-extensions=default,cookie,permissions".

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Rebuild "epiphany" adding "--with-gecko=xulrunner"
Actual results:
Configure stage aborts.

Expected results:
Configure stage completes successfully.

Additional info:
According to "xulrunner-mozconfig", "xulrunner" is built with
option "--enable-extensions=python/xpcom,default". "epiphany"
also requires extensions "cookies" and "permissions".
Comment 1 Marco Pesenti Gritti 2006-05-09 10:42:57 EDT
The xulrunner package is not yet ready for rawhide and it was shipped there by
mistake. I removed it now.

Note You need to log in before you can comment on or make changes to this bug.