Bug 191154 - "xulrunner" built with unsufficient extensions
Summary: "xulrunner" built with unsufficient extensions
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-09 09:53 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 14:42:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2006-05-09 09:53:10 UTC
Description of problem:
Building "epiphany" against "xulrunner" fails because the built-in
extensions of the latter are not sufficient. "configure" aborts with
the message: "configure: error: xulrunner needs to be compiled with
at least --enable-extensions=default,cookie,permissions".

Version-Release number of selected component (if applicable):
xulrunner-1.8.0.cvs20060505-1

How reproducible:
Always.

Steps to Reproduce:
1. Rebuild "epiphany" adding "--with-gecko=xulrunner"
  
Actual results:
Configure stage aborts.

Expected results:
Configure stage completes successfully.

Additional info:
According to "xulrunner-mozconfig", "xulrunner" is built with
option "--enable-extensions=python/xpcom,default". "epiphany"
also requires extensions "cookies" and "permissions".

Comment 1 Marco Pesenti Gritti 2006-05-09 14:42:57 UTC
The xulrunner package is not yet ready for rawhide and it was shipped there by
mistake. I removed it now.


Note You need to log in before you can comment on or make changes to this bug.