Bug 191164 - Incorrect syntax for postalAddress attribute
Incorrect syntax for postalAddress attribute
Status: CLOSED DUPLICATE of bug 196918
Product: 389
Classification: Community
Component: Database - General (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-09 09:08 EDT by Paul Engle
Modified: 2008-08-11 19:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 13:02:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Engle 2006-05-09 09:08:48 EDT
Description of problem:

I just installed Fedora Directory Server 1.0.2 on a RHEL4 server, and discovered
a problem with the core schema. The postalAddress attribute had a syntax OID of
1.3.6.1.4.1.1466.115.121.1.15 (Directory String), but RFC 2256 states that this
attribute should have syntax OID 1.3.6.1.4.1.1466.115.121.1.41 (Postal Address). 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Start DS console
2. Under Configuration tab, select Schema from browser tree
3. Select Attributes tab
4. Scroll down to postalAddress attribute and observe Syntax name
  
Actual results:
Directory String

Expected results:
Postal Address

Additional info:

I was able to manually fix it by editing the 00core.ldif schema file.
Comment 1 Noriko Hosoi 2006-06-20 13:24:39 EDT
It looks we should review the entire schema files.  Just brief checking around
postalAddress, I could find these attributes mismatched the ones in 00core.ldif:

http://rfc.net/rfc2256.html
5.17. postalAddress
   ( 2.5.4.16 NAME 'postalAddress' EQUALITY caseIgnoreListMatch
     SUBSTR caseIgnoreListSubstringsMatch
     SYNTAX 1.3.6.1.4.1.1466.115.121.1.41 )

5.28. destinationIndicator
   This attribute is used for the telegram service.
    ( 2.5.4.27 NAME 'destinationIndicator' EQUALITY caseIgnoreMatch
      SUBSTR caseIgnoreSubstringsMatch
      SYNTAX 1.3.6.1.4.1.1466.115.121.1.44{128} )

5.30. presentationAddress
   This attribute contains an OSI presentation address.
    ( 2.5.4.29 NAME 'presentationAddress'
      EQUALITY presentationAddressMatch
      SYNTAX 1.3.6.1.4.1.1466.115.121.1.43
      SINGLE-VALUE )

5.31. supportedApplicationContext
   This attribute contains the identifiers of OSI application contexts.
    ( 2.5.4.30 NAME 'supportedApplicationContext'
      EQUALITY objectIdentifierMatch
      SYNTAX 1.3.6.1.4.1.1466.115.121.1.38 )
Comment 2 Orla Hegarty 2006-06-27 13:02:57 EDT
Closing - new more general bug has been filed which will include the fix for this.

*** This bug has been marked as a duplicate of 196918 ***
Comment 3 Chandrasekar Kannan 2008-08-11 19:46:32 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.