Bug 191196 - rpm -U leaves file descriptors open when exec-ing daemon
rpm -U leaves file descriptors open when exec-ing daemon
Status: CLOSED DUPLICATE of bug 147717
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-09 14:19 EDT by Jeffrey Moyer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 15:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Moyer 2006-05-09 14:19:00 EDT
Description of problem:
See Bug 161298.  Basically, if you ssh to a box, rpm -U autofs, you cannot
logout because at least one file descriptor is left open.

I've change autofs to close all fds from 0-255, which works around the problem.

Version-Release number of selected component (if applicable):
rpm-4.3.3-7_nonptl

How reproducible:
100%
Comment 2 Jeffrey Moyer 2006-05-09 15:23:57 EDT
Yes, I've confirmed that the new version of RPM fixes this.  Thanks, Paul!

*** This bug has been marked as a duplicate of 147717 ***

Note You need to log in before you can comment on or make changes to this bug.