Bug 19120 - The "czsk" keymap does not work on XFree86 v3 servers
The "czsk" keymap does not work on XFree86 v3 servers
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-14 18:04 EDT by Jan "Yenya" Kasprzak
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 14:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2000-10-14 18:04:14 EDT
There is a problem with Czech and/or Slovak X11 keymap (as defined in
/usr/X11R6/lib/X11/xkb/symbols/czsk). This keymap fails horribly when
used with XFree86 version 3 servers. It works correctly on XFree86 version
4 server,
but this server does not have drivers for all cards version 3 had, for
example
my S3 Trio64V+).

To verify the problem: The Czech keyboard should work the following way:
- set up the following XKB lines in XF86Config (for XFree86 3.x), section
"Keyboard":
     XkbSymbols  "czsk(us_cz_qwerty)"
     XkbCompat   "group_led"
- run  X server with this config
- run LC_CTYPE=cs_CZ gnome-terminal --font=<some-font>-iso8859-2
- press Scroll Lock to switch to the Czech keyboard
- the upper row of the keyboard (normally prints numbers) should in this
gnome-terminal
      print the following symbols instead (for 1,2,...9,0 keys): plus,
ecaron, scaron,  ccaron,
      rcaron, zcaron, yacute, aacute, iacute, eacute.

The above works in RH6.x with XFree86-3.x server and in 7.0 with
XFree86-4.x server.
But with 7.0 and XFree86-3.x servers, the keyboard does not work, and is
completely
messed up. For example NumLock does not work,Right Alt does not work
(making it
impossible to switch the consoles using ctrl-alt-Fn or kill the server
using ctrl-alt-backspace.

I solved it on my system by copying the /usr/X11R6/lib/X11/xkb/symbols/czsk
file
from the Red Hat 6.x system and applying the patch to
/usr/X11R6/lib/X11/locale/iso8859-2/XLC_LOCALE. The patch can be found at
http://ftp.linux.cz/pub/linux/people/jan_kasprzak/XLC_LOCALE.patch.
Comment 1 Mike A. Harris 2001-03-06 12:39:56 EST
Please try the latest package at:
people.redhat.com/mharris/xfree86/4.0.2-11.4.0

If it does not fix it, let me know and I'll look deeper into the issue.
Comment 2 Jan "Yenya" Kasprzak 2001-03-07 14:48:25 EST
I have downloaded your RPMs, installed it (after upgrading freetype,
Mesa and Glide from Red Hat Wolverine), and tested: On my
RH 7.0 box with S3 Trio64V+ (XFree86-S3 server) the Czech keyboard
does not work either. After replacing /usr/X11R6/lib/X11/xkb/symbols/czsk
file by the one from XFree86-S3 in Red Hat 6.2 (RCS id of this file
is "czsk,v 1.1.2.2 1999/07/22 14:21:30 hohndel Exp") and restarting
the X server the Czech keyboard works. When using an XFree86-4
server (on a different graphic chip, of course), the Czech keyboard
works even without this change (as it used to do with stock
RH 7.0 RPMs).

It seems the problem is only with XFree86-3.x X servers (and your new
RPMs did not change that). The XLC_LOCALE patch above is no longer
necessary, though. Just the xkb/symbols/czsk does not work with
XFree86-3.x X server.

Comment 3 Mike A. Harris 2001-07-16 03:51:51 EDT
This is something that will have to be fixed upstream by XFree86 developers,
or someone familiar with czsk keymaps.  Any patches or bugfixes should be
submitted directly to XFree86 for fastest integration.

Submit any fixes to: fixes@xfree86.org

Note You need to log in before you can comment on or make changes to this bug.