Bug 1912114 - Missing aarch64 container
Summary: Missing aarch64 container
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Container Images
Classification: Fedora
Component: fedora-toolbox
Version: 33
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ondřej Míchal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-03 15:28 UTC by Stanislav Graf
Modified: 2021-01-04 13:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-04 13:00:48 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github containers toolbox issues 528 0 None closed Missing fedora-toolbox image for aarch64 2021-01-04 13:00:17 UTC

Description Stanislav Graf 2021-01-03 15:28:43 UTC
Description of problem:

~~~
$ toolbox create
Image required to create toolbox container.
Download registry.fedoraproject.org/f33/fedora-toolbox:33 (500MB)? [y/N]: y
Error: failed to pull image registry.fedoraproject.org/f33/fedora-toolbox:33

$ skopeo inspect --raw docker://registry.fedoraproject.org/f33/fedora-toolbox
{
    "manifests": [
        {
            "digest": "sha256:69647ef6d4851a39c2a792abe2e558795b290b24b6739dc687201bd3c7a07042",
            "mediaType": "application/vnd.docker.distribution.manifest.v2+json",
            "platform": {
                "architecture": "amd64",
                "os": "linux"
            },
            "size": 741
        }
    ],
    "mediaType": "application/vnd.docker.distribution.manifest.list.v2+json",
    "schemaVersion": 2
~~~


Version-Release number of selected component (if applicable):
33

How reproducible:
100%

Steps to Reproduce:
1. Install Fedora Server on aarch64
2. run 'toolbox create'
3.

Actual results:
failed to pull image

Expected results:
toolbox container created

Additional info:
* It looks like there is only 1 arch available (amd64)

Comment 1 Ondřej Míchal 2021-01-03 16:30:43 UTC
Hi Stanislav,

support for aarch64 images was added very recently. We did not rebuild the images since then (about a month ago). I rebuilt the images a little while ago and submitted updates in Bodhi. When the images get to the registry, the `toolbox create` command should start working normally.

Until the images go stable, you can use the image from the candidate registry like this:

$ toolbox create -i candidate-registry.fedoraproject.org/f33/fedora-toolbox:latest

I'm not 100% sure if the rebuilt images are in the candidate registry already but they should get there pretty soon.

Comment 2 Stanislav Graf 2021-01-03 19:27:20 UTC
(In reply to Ondřej Míchal from comment #1)

Thanks, image from the candidate registry works.


Note You need to log in before you can comment on or make changes to this bug.