Bug 19122 - Fails install
Fails install
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-14 20:11 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-15 13:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Text from anaconda (984 bytes, text/plain)
2000-10-14 20:12 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-10-14 20:11:31 EDT
I got 3 disks. Disk /hda is used for W2000. Disk /hdb and /hdc should be 
used for linux.

The install goes well until formating of the disks. After 
formatting /usr/, /usr/local and /home it fails with this error 
message.Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/cdisk

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Need Real Name 2000-10-14 20:12:57 EDT
Created attachment 4166 [details]
Text from anaconda
Comment 2 dpaolett 2000-10-15 13:31:44 EDT
I encountered the same exact bug; it occurred right after formatting partitions
(only formatted /).  System details: Athlon 850, 128MB RAM, TNT2 Ultra.

/dev/hda  LILO installed on MBR
/dev/hda1 Win98, uses entire drive

/dev/hdd1 /
/dev/hdd5 /home
/dev/hdd6 /usr/local
/dev/hdd7 swap
Comment 3 Daniel Roesen 2000-10-17 07:21:17 EDT
Errata update available.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.