Bug 19124 - 16 meg machine did not get 'not enough ram' warning
16 meg machine did not get 'not enough ram' warning
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-14 20:45 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 14:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-14 20:45:04 EDT
First of all, I apologise for any shortcomings in this report; I know 
little about Linux or Unix.

RH Linux 7.0 hard disk installation apparently proceeds as normal at first.

* The "Loading mnt/runtime ramdisk..." announcement appears and disappears.

* The "Loading mnt/runtime/usr ramdisk..." announcement appears and 
disappears.

* In expert mode, the "special drivers" dialog appears and disappears when 
finished.

Running anaconda -- may take some time to load...

	appears at the bottom of the screen. A few seconds later, it is 
followed by

install exited abnormally -- received signal 9
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems
	/mnt/runtime/usr
	/mnt/runtime
	/dev/pts
	/proc
you may safely reboot your system

I have "successfully" reproduced this bug every time I attempt to install 
on my PC. Using or omitting any of these boot options:

	linux mem=16M
	expert
	text
	update

has no visible effect on it. Nor does changing the language or keyboard 
selection.

Neither /tmp/syslog nor <the output to the alt-F3 console> show any 
obvious relevant error messages. Here is the /tmp/syslog produced in a 
typical install attempt:

<4>Linux version 2.2.16-22BOOT (root@porky.devel.redhat.com) (gcc version 
egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Tue Aug 22 15:35:29 
EDT 2000
<4>Detected 119753 kHz processor.
<4>Console: colour VGA+ 80x25
<4>Calibrating delay loop... 238.39 BogoMIPS
<4>Memory: 13572k/16384k available (1016k kernel code, 416k reserved, 548k 
data, 60k init, 0k bigmem)
<4>Dentry hash table entries: 262144 (order 9, 2048k)
<4>Buffer cache hash table entries: 16384 (order 4, 64k)
<4>Page cache hash table entries: 4096 (order 2, 16k)
<4>CPU: Intel Pentium 75 - 200 stepping 0c
<6>Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
<6>Checking 'hlt' instruction... OK.
<6>Checking for popad bug... OK.
<6>Intel Pentium with F0 0F bug - workaround enabled.
<4>POSIX conformance testing by UNIFIX
<4>PCI: PCI BIOS revision 2.10 entry at 0xfd8a1
<4>PCI: Using configuration type 1
<4>PCI: Probing PCI hardware
<6>Linux NET4.0 for Linux 2.2
<6>Based upon Swansea University Computer Society NET3.039
<6>NET4: Unix domain sockets 1.0 for Linux NET4.0.
<6>NET4: Linux TCP/IP 1.0 for NET4.0
<6>IP Protocols: ICMP, UDP, TCP
<4>TCP: Hash tables configured (ehash 16384 bhash 16384)
<4>Starting kswapd v 1.5 
<6>Detected PS/2 Mouse Port.
<6>Serial driver version 4.27 with no serial options enabled
<6>ttyS00 at 0x03f8 (irq = 4) is a 16550A
<6>ttyS01 at 0x02f8 (irq = 3) is a 16550A
<6>ttyS02 at 0x03e8 (irq = 4) is a 16550A
<4>pty: 256 Unix98 ptys configured
<4>RAM disk driver initialized:  16 RAM disks of 4096K size
<6>loop: registered device at major 7
<4>PIIX3: IDE controller on PCI bus 00 dev 39
<4>PIIX3: not 100% native mode: will probe irqs later
<4>    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
<4>    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
<4>hda: Seagate Technology 1275MB - ST31276A, ATA DISK drive
<4>hdb: QUANTUM FIREBALLlct15 15, ATA DISK drive
<4>hdc: TOSHIBA CD-ROM XM-5602B, ATAPI CDROM drive
<4>ide2: ports already in use, skipping probe
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<4>ide1 at 0x170-0x177,0x376 on irq 15
<6>hda: Seagate Technology 1275MB - ST31276A, 1221MB w/0kB Cache, 
CHS=620/64/63
<6>hdb: QUANTUM FIREBALLlct15 15, 14324MB w/418kB Cache, CHS=1826/255/63
<4>hdc: ATAPI 8X CD-ROM drive, 256kB Cache
<6>Uniform CD-ROM driver Revision: 3.10
<6>Floppy drive(s): fd0 is 1.44M
<6>FDC 0 is a National Semiconductor PC87306
<6>md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
<6>raid5: measuring checksumming speed
<4>   8regs     :   122.301 MB/sec
<4>   32regs    :    89.916 MB/sec
<4>using fastest function: 8regs (122.301 MB/sec)
<4>scsi : 0 hosts.
<4>scsi : detected total.
<4>md.c: sizeof(mdp_super_t) = 4096
<4>Partition check:
<4> hda: hda1 hda2 < hda5 > hda4
<4> hdb: hdb1 hdb2 hdb3 hdb4 < hdb5 >
<5>RAMDISK: Compressed image found at block 0
<4>VFS: Mounted root (ext2 filesystem).
<4>EXT2-fs warning: maximal mount count reached, running e2fsck is 
recommended
<6>raid0 personality registered
<6>raid1 personality registered
<6>raid5 personality registered

I scribbled down the last few messages from the alt-F3 console from the 
same install attempt:

* partition /dev/hdb3 selected
* mounting device hdb3 as ext2
* created inode
* done loading 2969600 bytes
* created inode
* done loading 4194304 bytes
* got url hd://hdb3:ext2/rh7/i386/en
* found url image hd://hdb3:ext2/rh7/i386/en
* getting ready to spawn shell now
* going to insmod raid0.o (path is NULL)
* going to insmod raid1.o (path is NULL)
* going to insmod raid5.o (path is NULL)
* going to insmod ext3.o (path is NULL)
* looking for USB mouse...

The /proc/cmdline from that attempt was:

initrd=initrd.img devfs=nomount BOOT_IMAGE=vmlinuz mem=16M expert text 
update

All the information about my computer in the /tmp/syslog above appears to 
be correct. Additionally, I can tell you that it is an AST Advantage! 7302 
(with a new HD and a replaced modem) and the BIOS version is 1.00.05CW0Q - 
unfortunately I don't have a name for the motherboard or chipset.

Possible problems I have considered include:

1) Corrupt files? The md5sums of the copies of these files

	RedHat/base/comps		8a867969ae6c1d5ff19626f7bddfa23f
	RedHat/base/hdlist		2d50d4d3a4f6ca7751c4d681c2096999
	RedHat/base/hdstg1.img		74b2687122604d51ffc526607b4f654b
	RedHat/base/hdstg2.img		a9dd42f21392bea6453bd8cb04a21b02
	images/boot.img			c4df79650c81960d6f8807a36e014e40

	in /dev/hda3 appear to be correct (or at least, they are the same 
as those on ftp.ibiblio.org). I have created new boot floppies from 
boot.img a number of times.

2) Bad hardware? My computer is successfully running both Windows 95 (OEM 
release 1) and Red Hat 6.0, which was successfully (re)installed (from CD, 
without a boot floppy) a few days ago. All the RAM is good. Both hard 
drives have been operating successfully under both OSes. The partitions on 
both were successfully detected by the 7.0 installer, and I was able to 
mount, unmount and use partitions on both drives from the alt-F2 
console's /bin/sh prompt without problems. OTOH, the IDE controller with 
the hard drives is sometimes very slow to respond to the BIOS at boot, and 
I've had two corrupt ext2 superblocks recently (why I don't know).

3) A software bug? I've tried running /usr/bin/anaconda from the alt-F2 
console's /bin/sh while the "special drivers" dialog was still up in the 
main console. The result was (copied by hand):

error 2 reading header: cpio: Bad magic
cpio failed on (null): (internal)
Segmentation fault

    (Entering /usr/bin/anaconda for a second time produces another 
segfault, with a much longer error message. If you try /usr/bin/anaconda 
and then proceed with the install, the same longer error message appears 
in the main console, and the install aborts on signal 11, not 9.)

4) Not enough RAM? I know that 16MB is pitiful these days, but don't tell 
me that you can't even *install* without more. If you can't, the installer 
should at least make that clear. There certainly shouldn't be any shortage 
of swap; /dev/hdb2 is a 128Mb Linux swap partition.

Please don't hesitate to email me if there is anything else I can add or 
check.
Comment 1 Need Real Name 2000-10-14 21:17:58 EDT
I made a small typo in the original description - the files with correct 
md5sums are in /dev/hdb3 (not /dev/hda3), along with all the rest of the 
downloaded files.
Comment 2 Alan Cox 2000-10-15 20:12:55 EDT
I agree the installer ought to do saner things but I suspect you are out of ram
with 15.5Mb. Try a text mode install. 

Bug left open since the 16Mb warning is a very valid point
Comment 3 Need Real Name 2000-10-15 23:41:38 EDT
Unfortunately, a text-mode installation seems to be impossible: text is one of 
the boot: options I have tried without seeing any change (see above). If this 
means that RHL 7.0 really can't be installed without >16MB RAM, then I would 
suggest that the online documentation needs changing: there doesn't seem to be 
any minimum physical RAM figure given for RHL 7.0 on RH's website. The nearest 
I could find was one for RHL 6.2, which was 16Mb. Also, Chapter 5 of the 7.0 
Reference Guide says that "If your computer has 16Mb of RAM or less, you must 
create a swap partition.", implying that 16Mb RAM is enough.
Comment 4 Michael Fulbright 2000-10-18 18:16:19 EDT
The text installer requires at least 20 megs to run.  It is a bug it did not
inform you that 16 megs was not going to be enough.
Comment 5 Need Real Name 2000-10-26 17:46:31 EDT
I can confirm that diagnosis. RHL now installs successfully after an upgrade to 
48MB.
Comment 6 Michael Fulbright 2000-10-27 16:25:05 EDT
If you don't mind, what does /proc/meminfo report if you go back to the original
memory configuration that was causing problems?
Comment 7 Need Real Name 2000-10-27 23:42:59 EDT
Here is a typical /proc/meminfo from an installation attempt using the old
(16MB) memory configuration, taken when the expert mode "special drivers" dialog
was up:

        total:    used:    free:  shared: buffers:  cached:
Mem:  14688256 14311424   376832   446464  9027584  1290240
Swap:        0        0        0
MemTotal:     14344 kB
MemFree:        368 kB
MemShared:      436 kB
Buffers:       8816 kB
Cached:        1260 kB
BigTotal:         0 kB
BigFree:          0 kB
SwapTotal:        0 kB
SwapFree:         0 kB

The /proc/cmdline from that attempt was

expert initrd=initrd.img devfs=nomount BOOT_IMAGE=vmlinuz
Comment 8 Erik Troan 2001-01-12 14:04:01 EST
Added a really nasty "your system will now reboot" message for unsupported
machines.

Note You need to log in before you can comment on or make changes to this bug.