Bug 191250 - lignomeui - segfault from gnome_segv2
lignomeui - segfault from gnome_segv2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnomeui (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 01:51 EDT by Michal Jaegermann
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
captured gdb backtrace from segfault (3.44 KB, text/plain)
2006-05-10 01:51 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2006-05-10 01:51:58 EDT
Created attachment 128834 [details]
captured gdb backtrace from segfault
Comment 1 Michal Jaegermann 2006-05-10 01:51:58 EDT
Description of problem:

After an upgrade to FC5 root cannot start X because on every attempt
the following shows up in logs and gnome-session terminates:

gnome_segv2[3585]: segfault at 0000000000000010 rip 00002aaaacaf3a08 rsp
00007fffffaa89b0 error 4

This probably depends on what was found already in ~/.gnome* and similar
because on another account it is possible to start gnome-session and it
seems to run.  OTOH root configuration was left in principle at defaults
while this other account is quite substantially customized.

By replacing /usr/libexec/gnome_segv2 by a script which runs the real
executable under gdb, with libgnomeui-debuginfo installed, it is possible
to find that segfault happens at gnome_segv.c:182.  A backtrace from
gdm, with the following .gdbinit file

set args gnome-session 11 2.14.1
run
bt
frame 21
list
print mainwin
print *mainwin
print res

is attached.

This is filed arch specific as I observed that on a particular machine
which happens to be x86_64.

Version-Release number of selected component (if applicable):
libgnomeui-2.14.1-1.fc5.1

How reproducible:
always on that particular account
Comment 2 Ray Strode [halfline] 2008-03-18 14:33:38 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.