Bug 1912531 - kubectl dep bump for drain busy loop
Summary: kubectl dep bump for drain busy loop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.z
Assignee: Michael Gugino
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On: 1912527
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-04 16:32 UTC by Michael Gugino
Modified: 2021-03-16 23:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1912527
Environment:
Last Closed: 2021-03-16 23:22:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-aws pull 388 0 None open "Bug 1912531: revendor mao" 2021-02-18 01:35:17 UTC
Github openshift cluster-api-provider-azure pull 199 0 None open "Bug 1912531: revendor mao" 2021-02-18 01:35:17 UTC
Github openshift cluster-api-provider-baremetal pull 137 0 None open "Bug 1912531: revendor mao" 2021-02-18 01:35:17 UTC
Github openshift cluster-api-provider-gcp pull 149 0 None open "Bug 1912531: revendor mao" 2021-02-18 01:35:18 UTC
Github openshift cluster-api-provider-openstack pull 164 0 None open "Bug 1912531: revendor mao" 2021-02-18 01:35:18 UTC
Github openshift machine-api-operator pull 782 0 None closed Bug 1912531: 4.6: Update kubectl dep 2021-02-18 01:35:18 UTC
Red Hat Product Errata RHBA-2021:0753 0 None None None 2021-03-16 23:22:34 UTC

Description Michael Gugino 2021-01-04 16:32:43 UTC
+++ This bug was initially created as a clone of Bug #1912527 +++



--- Additional comment from Michael Gugino on 2021-01-04 16:31:01 UTC ---

Need this bug for backport.  Fixed in master: https://github.com/openshift/machine-api-operator/pull/771

Comment 2 sunzhaohua 2021-01-22 05:58:46 UTC
Verified
Reproduced this on 4.5
step: 
1) create a pdb
2) drain the node with Pods containing the pdb
3) check CPU usage
Tested with 4.6.0-0.ci.test-2021-01-20-020322-ci-ln-4i1q07t (setup cluster using cluster-bot) , all work as expected

Comment 5 brad.williams 2021-02-12 21:03:54 UTC
Per request from QE, the release-controller has automation that processes all "Accepted", nightly, releases for their respective bugs.  The automation will automatically move any bug, that was both reviewed and LGTM'd by the bug's QA Contact, to VERIFIED.

Comment 6 Joel Speed 2021-02-25 14:07:01 UTC
We are still waiting on cherry-pick approval for this, nothing further to be done by us for this

Comment 8 sunzhaohua 2021-03-05 06:33:14 UTC
based on Comment 2, this was verified, tested again on aws, it passed.
clusterversion: 4.6.0-0.nightly-2021-03-05-010246

Comment 11 errata-xmlrpc 2021-03-16 23:22:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0753


Note You need to log in before you can comment on or make changes to this bug.