Bug 1912566 - p&f: carry 97206: clean up executing request on panic
Summary: p&f: carry 97206: clean up executing request on panic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.z
Assignee: Abu Kashem
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1912564
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-04 19:10 UTC by Abu Kashem
Modified: 2021-05-06 09:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1912564
Environment:
Last Closed: 2021-02-02 15:10:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25777 0 None closed Bug 1912566: UPSTREAM: 97206: clean up executing request on panic 2021-02-15 21:01:28 UTC
Red Hat Product Errata RHBA-2021:0231 0 None None None 2021-02-02 15:10:38 UTC

Description Abu Kashem 2021-01-04 19:10:45 UTC
+++ This bug was initially created as a clone of Bug #1912564 +++

+++ This bug was initially created as a clone of Bug #1912563 +++

Description of problem:
p&f: clean up executing request on panic

carry upstream PR: https://github.com/kubernetes/kubernetes/pull/97206

Comment 2 Ke Wang 2021-01-22 10:01:11 UTC
There is no an e2e test to reproduce this issue, so need to rely on the unit tests here,

$ cd origin

$ git checkout -b 4.5 remotes/origin/release-4.5

$ git pull

$ oc adm release info --commits registry.ci.openshift.org/ocp/release:4.5.0-0.nightly-2021-01-21-233035 | grep origin
  hyperkube          https://github.com/openshift/origin          65bd32d2f3f16fa48cbc3501c448c4f4aeaf5566
  tests              https://github.com/openshift/origin          65bd32d2f3f16fa48cbc3501c448c4f4aeaf5566

$ oc get no
NAME                                         STATUS   ROLES    AGE     VERSION
ip-10-0-140-24.us-east-2.compute.internal    Ready    master   3h10m   v1.18.3+f561b20
ip-10-0-144-205.us-east-2.compute.internal   Ready    worker   179m    v1.18.3+f561b20
ip-10-0-179-181.us-east-2.compute.internal   Ready    worker   179m    v1.18.3+f561b20
ip-10-0-186-228.us-east-2.compute.internal   Ready    master   3h10m   v1.18.3+f561b20
ip-10-0-192-16.us-east-2.compute.internal    Ready    master   3h10m   v1.18.3+f561b20
ip-10-0-195-214.us-east-2.compute.internal   Ready    worker   179m    v1.18.3+f561b20

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2021-01-21-233035   True        False         169m    Cluster version is 4.5.0-0.nightly-2021-01-21-233035

$ cd <$GOPATH/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/staging/src/k8s.io/apiserver/pkg/util/flowcontrol/fairqueuing/queueset

$ go test -v -run TestTotalRequestsExecutingWithPanic
go: downloading github.com/pkg/errors v0.8.1
go: downloading k8s.io/klog v1.0.0
go: downloading github.com/prometheus/common v0.4.1
go: downloading github.com/prometheus/client_golang v1.0.0
go: downloading github.com/blang/semver v3.5.0+incompatible
go: downloading github.com/golang/protobuf v1.3.2
go: downloading github.com/prometheus/procfs v0.0.2
go: downloading github.com/matttproud/golang_protobuf_extensions v1.0.1
go: downloading github.com/beorn7/perks v1.0.0
=== RUN   TestTotalRequestsExecutingWithPanic
--- PASS: TestTotalRequestsExecutingWithPanic (0.00s)
PASS
ok  	k8s.io/apiserver/pkg/util/flowcontrol/fairqueuing/queueset	0.005s

All is well, move the bug VERIFIED.

Comment 5 errata-xmlrpc 2021-02-02 15:10:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.30 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0231


Note You need to log in before you can comment on or make changes to this bug.