Bug 1912898 - [Regression] Traceback when configuring a bond on the kernel command line
Summary: [Regression] Traceback when configuring a bond on the kernel command line
Keywords:
Status: CLOSED DUPLICATE of bug 1890009
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 8.0
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-05 14:46 UTC by Renaud Métrich
Modified: 2021-04-27 20:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-27 19:59:46 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Logs (46.90 KB, application/gzip)
2021-01-07 10:50 UTC, Renaud Métrich
no flags Details
Update image containing the fix from Upstream (4.51 KB, application/gzip)
2021-03-10 10:00 UTC, Renaud Métrich
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 5872751 0 None None None 2021-03-10 11:04:51 UTC

Description Renaud Métrich 2021-01-05 14:46:45 UTC
Description of problem:

This seems to be regression compared to 8.2.
When configuring a bond on the kernel command line, the following backtrace is seen after anaconda starts:
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------
anaconda 33.16.3.26-1.el8 for Red Hat Enterprise Linux 8.3 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * if the graphical installation interface fails to start, try again with the
   inst.text bootoption to start text installation
 * when reporting a bug add logs from /tmp as separate text/plain attachments
Traceback (most recent call last):
  File "/sbin/anaconda", line 555, in <module>
    initialize_network()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/network.py", line 290, in
initialize_network
    run_network_initialization_task(network_proxy.DumpMissingIfcfgFilesWithTask())
  File "/usr/lib64/python3.6/site-packages/pyanaconda/network.py", line 268, in
run_network_initialization_task
    sync_run_task(task_proxy)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/modules/common/task/__init__.py", line 46, in sync_run_task
    task_proxy.Finish()
  File "/usr/lib/python3.6/site-packages/dasbus/client/handler.py", line 447, in _call_method
    **kwargs,
  File "/usr/lib/python3.6/site-packages/dasbus/client/handler.py", line 477, in _get_method_reply
    return self._handle_method_error(error)                                    
  File "/usr/lib/python3.6/site-packages/dasbus/client/handler.py", line 497, in _handle_method_error
    raise exception from None
dasbus.error.DBusError: 'NoneType' object has no attribute 'set_property'
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------

This prevents installing.


Version-Release number of selected component (if applicable):

anaconda-33.16.3.26-1.el8

How reproducible:

Always

Steps to Reproduce:
1. Set up a VM with 2 network interfaces on same network

 - disconnect link 2 for convenience if you don't have real bonding available (my case)

2. Boot on the network using the following bond configuration

  ip=bond0:dhcp bond=bond0:enp1s0,enp2s0:mode=active-backup


Actual results:

Traceback

Expected results:

No traceback

Additional info:

Doesn't happen on RHEL8.1, 8.2 and 7.9

Comment 1 Jiri Konecny 2021-01-06 10:33:01 UTC
Could you please provide us logs from the installation. You can find them in /tmp/*.log during the installation.

Comment 4 Renaud Métrich 2021-01-07 10:50:54 UTC
Created attachment 1745262 [details]
Logs

Comment 8 Renaud Métrich 2021-03-10 10:00:42 UTC
Created attachment 1762242 [details]
Update image containing the fix from Upstream

Comment 9 Radek Vykydal 2021-04-15 14:53:17 UTC
(In reply to Masahiro Matsuya from comment #7)
> The one line fix is in upstream:
>  
> https://github.com/rhinstaller/anaconda/commit/
> a3e46c49216f76f73097587b15ded52b253ce3d2
> 
> NM.SettingWired is not used for bond device. So, get_setting_wired() doesn't
> return anything.
> 
> RHEL 8.4 Beta has already had the fix. So, it doesn't happen in RHEL8.4 Beta.
> 

Thank you for the debugging.
The rhel-8 commit is in
https://github.com/rhinstaller/anaconda/pull/2938
and I agree that it should fix this BZ.

Comment 10 Jan Stodola 2021-04-27 19:55:09 UTC
Just a note that this can be reproduced on RHEL-8.3 when the bond device configuration is before the ip= argument on the kernel command line:

bond=bond0:enp1s0,enp2s0:mode=active-backup ip=bond0:dhcp

I wasn't able to reproduce with the order "ip=bond0:dhcp bond=... "

Comment 11 Jan Stodola 2021-04-27 19:59:46 UTC
And since this bug is fixed in RHEL-8.4, I'm closing it as a duplicate of 1890009.

*** This bug has been marked as a duplicate of bug 1890009 ***


Note You need to log in before you can comment on or make changes to this bug.