Bug 1912917 - calamares fails to build with Python 3.10: undefined reference to `_Py_fopen'
Summary: calamares fails to build with Python 3.10: undefined reference to `_Py_fopen'
Keywords:
Status: CLOSED DUPLICATE of bug 1912903
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonathan Wakely
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1912903
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-05 15:34 UTC by Tomáš Hrnčiar
Modified: 2021-01-05 16:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-05 16:25:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-05 15:34:17 UTC
calamares fails to build with Python 3.10.0a4.

/usr/bin/ld: /usr/lib64/libboost_python310.so.1.73.0: undefined reference to `_Py_fopen'

bpo-32381: Remove the private _Py_fopen() function which is no longer needed. Use _Py_wfopen() or _Py_fopen_obj() instead.

https://docs.python.org/3.10/whatsnew/changelog.html#c-api

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01859511-calamares/

For all our attempts to build calamares with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/calamares/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Kevin Kofler 2021-01-05 16:25:04 UTC
This reference comes from Boost::Python. Calamares does not use _Py_fopen directly.

*** This bug has been marked as a duplicate of bug 1912903 ***


Note You need to log in before you can comment on or make changes to this bug.