This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 191296 - Failure to build unison 2.13.16 from src.rpm
Failure to build unison 2.13.16 from src.rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lablgtk (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 12:32 EDT by Edward Grace
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 13:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Grace 2006-05-10 12:32:23 EDT
Description of problem:

Failure to build unison 2.13.16 from src.rpm


Version-Release number of selected component (if applicable):

2.13.16

How reproducible:

Always


Steps to Reproduce:
1. Configure rpm build
2. Download unison-2.13.16-2.fc5.src.rpm
3. chdir to SPECS
4. do rpmbuild -ba unison

 
Actual results:

Failure to link.  Compile stage works, then the following error occurs

Failure message of the form:
Linking unison
ocamlopt -verbose -I lwt -I ubase -I +lablgtk2 -o unison   unix.cmxa str.cmxa
lablgtk.cmxa -cclib -lutil ubase/projectInfo.cmx ubase/myMap.cmx
ubase/safelist.cmx ubase/uprintf.cmx ubase/util.cmx ubase/rx.cmx ubase/uarg.cmx
ubase/prefs.cmx ubase/trace.cmx lwt/pqueue.cmx lwt/lwt.cmx lwt/lwt_util.cmx
lwt/lwt_unix.cmx case.cmx pred.cmx uutil.cmx fileutil.cmx name.cmx path.cmx
fspath.cmx fingerprint.cmx abort.cmx osx.cmx props.cmx fileinfo.cmx os.cmx
lock.cmx clroot.cmx common.cmx tree.cmx checksum.cmx terminal.cmx transfer.cmx
xferhint.cmx remote.cmx copy.cmx globals.cmx update.cmx files.cmx sortri.cmx
recon.cmx transport.cmx strings.cmx uicommon.cmx uitext.cmx main.cmx pixmaps.cmx
uigtk2.cmx linkgtk2.cmx osxsupport.o pty.o
Files /usr/lib/ocaml/lablgtk2/lablgtk.cmxa and /usr/lib/ocaml/stdlib.cmxa
make inconsistent assumptions over implementation Printf
make: *** [unison] Error 2
error: Bad exit status from /export/scratch/graceej/rpmbuild/TMP/rpm-tmp.20219
(%build)


RPM build errors:
    Bad exit status from /export/scratch/graceej/rpmbuild/TMP/rpm-tmp.20219 (%build)
[



Expected results:

Build of the appropriate rpm

Additional info:

I am attempting to build this package from source so I can attempt a build of
the beta version of unison to see if it fixes bug #191295
Comment 1 Gérard Milmeister 2006-05-10 13:47:55 EDT
Thanks for notifying. This is due to a new build of ocaml, lablgtk rebuilds
are in the queue.
Comment 2 Edward Grace 2006-05-16 04:26:19 EDT
Would you please notify me when the updated packages of Ocaml et al. are all
sorted?  That way I can try building the new version of unison to see if it
fixes bug 191295.

Thanks.
Comment 3 Edward Grace 2006-05-16 04:32:38 EDT
Sorry.  I take that all back!  Like an idiot I didn't try doing an update before
recompiling.  Unison 2.13.16 now builds just fine.  

Note You need to log in before you can comment on or make changes to this bug.