Bug 191308 - Less doesn't display plain files
Less doesn't display plain files
Status: CLOSED DUPLICATE of bug 190619
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 13:54 EDT by Penelope Fudd
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-11 08:51:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2006-05-10 13:54:15 EDT
Description of problem:
For some reason, less isn't displaying the contents of files.

Version-Release number of selected component (if applicable):
less-394-3

How reproducible:
All the time

Steps to Reproduce:
1. rpm -qa | grep perl > /tmp/perlfiles
2. less /tmp/perlfiles
3.
  
Actual results:
No output

Expected results:
The contents of the file

Additional info:
I've fixed the bug by adding one line to /usr/bin/lesspipe.sh at line 39:
        DECOMPRESSOR="cat"
Without that line, the command line for plain files is " -- $1", which doesn't
do anything.
Comment 1 Ivana Varekova 2006-05-11 08:51:55 EDT
This problem should be fixed in less-394-4.

*** This bug has been marked as a duplicate of 190619 ***

Note You need to log in before you can comment on or make changes to this bug.