Bug 1913151 - KubeVirt platform: User running the installer must have vm update permission - documentation missing
Summary: KubeVirt platform: User running the installer must have vm update permission ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.7.0
Assignee: Nir Argaman
QA Contact: Chen Yosef
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-06 06:49 UTC by Nir Argaman
Modified: 2021-01-10 08:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-10 08:14:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4521 0 None Waiting on Customer [RFE] Podman and shadow-utils need support for non local users 2022-05-10 17:53:01 UTC

Description Nir Argaman 2021-01-06 06:49:52 UTC
Version:
bin/openshift-install unreleased-master-4110-g16557d92e1587512bb4bd6fe58ab8606f69a009f
built from commit 16557d92e1587512bb4bd6fe58ab8606f69a009f
release image registry.svc.ci.openshift.org/origin/release:4.7

Platform: KubeVirt

The error is in the user documentation
The role.yaml example (docs/user/kubevirt/role.yaml) is missing 
Virtual Machine resource verb: "update"
When this verb is missing, although the cluster is created successfully, but the cluster behavior after the installation is wrong (machine-controllers use the infra cluster credentials provided by the user)


Note You need to log in before you can comment on or make changes to this bug.