Bug 191328 - network should support --mtu argument
network should support --mtu argument
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 16:28 EDT by Philip Prindeville
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 10:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Prindeville 2006-05-10 16:28:50 EDT
Description of problem:

Sometimes when doing a network-based Kickstart install, you might not have a
full 1500 byte MTU available to you (such as when installing over a router using
a VPN tunnel to connect to a remote FTP or HTTP server).

Being able to explicitly specify the path MTU would make this more robust.

Version-Release number of selected component (if applicable):


How reproducible:

put "ifconfig -a" into your ks.cfg's %post file.  It will show the default MTU
(!500 bytes for ethernet eth0).


Steps to Reproduce:
1. n/a -- this is an enhancement request
2.
3.
  
Actual results:

n/a

Expected results:

Specifying:

network --device=eth0 --bootproto=dhcp onboot=on --mtu

should have two results:

(1) the interface eth0 gets (re)configured with "ifconfig eth0 mtu XXX" (or via
the appropriate ioctl) before the install process begins (including fetching any
remote files);

(2) the /etc/sysconfig/network-scripts/ifcfg-eth0 (or whatever) should have the
additional line "MTU=XXX" inserted.

Additional info:
Comment 1 Chris Lumens 2006-05-15 16:57:14 EDT
Committed to anaconda and pykickstart.  We'll test this out in the next anaconda
rebuild and see how it goes from there.
Comment 2 Chris Lumens 2006-05-23 22:39:36 EDT
Could you please test with Rawhide and see if this is working as you expect?
Comment 3 Philip Prindeville 2006-05-23 23:39:37 EDT
I can test it as a patch...

Can you point me at the diffs?
Comment 4 Chris Lumens 2006-05-25 18:06:54 EDT
It will probably be easiest for you to just wait until FC6test1, since this
requires changes to pykickstart, anaconda, and the loader.  The update process
for this is fairly complicated and unforgiving.

Note You need to log in before you can comment on or make changes to this bug.