Bug 191343 - Kickstart: 500 error on a Kickstart Create Profile page when no channels/trees
Kickstart: 500 error on a Kickstart Create Profile page when no channels/trees
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Beth Nackashi
:
Depends On:
Blocks: rhn410-kickstart
  Show dependency treegraph
 
Reported: 2006-05-10 19:45 EDT by Mike McCune
Modified: 2007-10-29 21:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 16:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2006-05-10 19:45:55 EDT
1) Need a freshly installed satellite with NO channels or kickstart trees synced
2) Login to the webui
3) "Manage Kickstarts"
4) create new kickstart profile
5) notice 500 error.

Should see:

"No Kickstartable Channels found."

"No trees were found for the selected channel"
Comment 1 Mike McCune 2006-05-11 12:02:07 EDT
NOTE: Even with channels synced it still blows up.  So, this bug is basically
stating that the profile creation page is non functional on a satellite.
Comment 2 Mike McCune 2006-05-11 13:06:22 EDT
Upgrading to this RPM or greater will contains the fix for this issue:

rhn-java-4.1.0-583.noarch.rpm
rhn-java-config-4.1.0-583.noarch.rpm
rhn-java-lib-4.1.0-583.noarch.rpm
taskomatic-4.1.0-583.noarch.rpm

Comment 4 Jesus M. Rodriguez 2006-05-11 13:31:13 EDT
rhn-java-libs IS NOT a valid pkg so ignore that one, get the other 4.
Comment 5 Mike McCune 2006-05-23 17:48:45 EDT
mass move to ON_QA
Comment 6 Beth Nackashi 2006-05-25 11:44:54 EDT
moving from ON_DEV to ON_QA
Comment 7 Beth Nackashi 2006-05-25 11:50:19 EDT
retested on sat with:

[root@fjs-0-06 ~]# rpm -q taskomatic rhn-java rhn-java-lib rhn-java-config
taskomatic-4.1.0-608
rhn-java-4.1.0-608
rhn-java-lib-4.1.0-608
rhn-java-config-4.1.0-608
Comment 8 Beth Nackashi 2006-05-25 13:41:41 EDT
what?  it's 500-ing again.  I just tested it.

My sat has two base and three child channels synced:
13:38:47       p rhel-i386-as-4                           2867
13:38:48       p rhel-ia64-as-4                           3165
13:38:48       p redhat-rhn-proxy-4.1-as-i386-4            109
13:38:48       p rhn-tools-rhel-4-as-i386                  656
13:38:48       p rhn-tools-rhel-4-as-ia64                  596

And two external distributions created:
rhel-4-gold-as-i386-ext:
Red Hat Enterprise Linux AS (v. 4 for 32-bit x86)	 auto-kickstart-ks-rhel-i386-as-4

rhel-4-u3-as-i386:
Red Hat Enterprise Linux AS (v. 4 for 32-bit x86)	 auto-kickstart-ks-rhel-i386-as-4-u3

And I'm trying to create a profile called "ks-rhel-4-gold-as-i386-ext" using "rhel-4-gold-as-i386-
ext".

...

aw geez.  Now I see what the problem is.  I already have a profile by that name.  I'll create a new bug for 
this.
Comment 9 Beth Nackashi 2006-05-25 14:33:13 EDT
There is already an existing bug for the issue in Comment #8:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192883
Comment 10 Beth Nackashi 2006-07-19 16:29:20 EDT
moving to closed - currentrelease

Note You need to log in before you can comment on or make changes to this bug.