Bug 191344 - Include xpi in package?
Include xpi in package?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 19:54 EDT by Paul W. Frields
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 13:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2006-05-10 19:54:33 EDT
Description of problem:
The ChangeLog for liferea states (in part):

        * The source package now contains a Firefox
          extension (feedbag.xpi) that changes the
          live bookmarks button so that it will add
          add subscriptions directly to Liferea.

Any chance of getting this included in the package?  I see beagle includes
%{_libdir}/beagle/beagle.xpi, for example.
Comment 1 Brian Pepple 2006-05-10 20:00:49 EDT
I believe for that it needs to be built against Firefox, which is not currently
possible since FC doesn't provide a firefox-devel package.  When I get some free
time I'll look into this closer.
Comment 2 Paul W. Frields 2006-05-10 20:16:17 EDT
I don't know much about .xpi extension installers, but I don't think they need
to be "built."  They're ready to go.  (I checked the one in liferea and it does
indeed work "out of the box," so to speak.)  If you look at rpm -q --scripts
beagle, you can see how that maintainer did it.  Just a suggestion, thanks for
your time and packaging efforts!
Comment 3 Brian Pepple 2006-05-10 21:20:07 EDT
Yeah, they're not built, but the .jar's are packaged into something like
/usr/lib/firefox/chrome.  Regardless, this is a pretty low-priority item, and
when I get some free time I'll look at it further.
Comment 4 Brian Pepple 2006-05-18 13:16:01 EDT
This is being published as a Firefox extension at
https://addons.mozilla.org/firefox/2468/

Closing since this is being dropped from future tarballs.

Note You need to log in before you can comment on or make changes to this bug.