Bug 191359 - useradd: unknown GID 100
Summary: useradd: unknown GID 100
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: shadow-utils   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-11 05:57 UTC by Joachim Backes
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 15:29:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace useradd ... (4.59 KB, application/x-gzip)
2006-05-11 12:22 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2006-05-11 05:57:29 UTC
Description of problem:
ssh to some machine and then add some user by "useradd <some name>" on this
machine. Then the user will be added, but getting an error message: "useradd:
unknown GID 100". Getting no error message in FC4!


Version-Release number of selected component (if
applicable):shadow-utils-4.0.14-6.FC5




How reproducible: Each time


Steps to Reproduce:
1.ssh root@<target>
2.useradd <someuser>
3.
  
Actual results:
useradd: unknown GID 100


Expected results:
No message

Additional info:

Comment 1 Peter Vrabec 2006-05-11 12:09:21 UTC
I can't reproduce it. 
 
peter@a05-0705a ~ $ ssh root@wrabco 
root@wrabco's password: 
Last login: Tue May  2 14:36:38 2006 from aspr0n.redhat.usu 
wrabco ~ # useradd foo 
wrabco ~ # rpm -q shadow-utils 
shadow-utils-4.0.14-6.FC5 
wrabco ~ # rpm -q fedora-release 
fedora-release-5-5 
 

Comment 2 Joachim Backes 2006-05-11 12:21:49 UTC
I have made a "strace useradd eric" and I have attached the output (during a
script session).

Comment 3 Joachim Backes 2006-05-11 12:22:47 UTC
Created attachment 128881 [details]
strace useradd ...

Comment 4 Peter Vrabec 2006-05-11 12:50:00 UTC
Is there a group with ID 100 on your system? 
grep 100 /etc/group 

Comment 5 Joachim Backes 2006-05-11 12:58:55 UTC
No, only a group with groupid 1000.

Comment 6 Peter Vrabec 2006-05-11 13:06:52 UTC
So, that's the problem. 
 
Change your default group in /etc/default/useradd 
or 
create group with ID=100 
 
see: man useradd  
section default values 
 
 

Comment 7 Joachim Backes 2006-05-12 04:59:07 UTC
You are right, but if I use the useradd command together with the "-g <some
existing group>" option, then the warning about not existing gid 100 appears
too, and I think this is a bug. 

Comment 8 Peter Vrabec 2006-05-12 15:29:40 UTC
but the user is created. I don't consider this as a bug. You can try to report 
it to upstream.


Note You need to log in before you can comment on or make changes to this bug.