Bug 1913615 - python-ase: FTBFS in Fedora rawhide, AssertionError: assert len(w) == 0
Summary: python-ase: FTBFS in Fedora rawhide, AssertionError: assert len(w) == 0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-ase
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: marcindulak
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-07 09:10 UTC by Tomáš Hrnčiar
Modified: 2021-01-25 20:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-25 20:37:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-07 09:10:29 UTC
Description of problem:
Package python-ase fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
3.19.1-4.fc33

Steps to Reproduce:
koji build --scratch f34 python-ase-3.19.1-4.fc33.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-ase

Comment 1 marcindulak 2021-01-07 16:38:55 UTC
Is this message sent automatically? It would be good if the message included the actual command to run a test build.

The command below seems to triggers a python3.9 build

koji build --nowait --scratch f34 python-ase-3.20.1-1.fc33.src.rpm

https://koji.fedoraproject.org/koji/taskinfo?taskID=59117154

I guess a way to test python3.10 is to configure a local mock https://copr.fedorainfracloud.org/coprs/g/python/python3.10/,

```
cat ~/.config/mock/fedora-rawhide-python310.cfg
include('/etc/mock/fedora-rawhide-x86_64.cfg')

config_opts['root'] = 'fedora-rawhide-python310'

config_opts[f'{config_opts.package_manager}.conf'] += """

[python310]
name=Copr repo for python3.10 owned by @python
baseurl=https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-$basearch/
type=rpm-md
skip_if_unavailable=False
gpgcheck=1
gpgkey=https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/pubkey.gpg
repo_gpgcheck=0
enabled=1
enabled_metadata=1
cost=10
"""
```

```
mock -r fedora-rawhide-python310 --scrub=all
mock -r fedora-rawhide-python310 --enablerepo=local --no-bootstrap-chroot --rebuild python-ase-3.20.1-1.fc33.src.rpm

```

Comment 2 marcindulak 2021-01-07 16:39:45 UTC
However, then doing


```
mock -r fedora-rawhide-python310 --enablerepo=local --no-bootstrap-chroot --rebuild python-ase-3.20.1-1.fc33.src.rpm
```


I'm getting something that resembles https://bugzilla.redhat.com/show_bug.cgi?id=1906462, e.g:


```
==================================== ERRORS ====================================
______________________ ERROR collecting test_analysis.py _______________________
test_analysis.py:3: in <module>
    from ase.geometry.analysis import Analysis
../geometry/analysis.py:5: in <module>
    from ase.neighborlist import build_neighbor_list, get_distance_matrix, get_distance_indices
../neighborlist.py:4: in <module>
    from scipy.spatial import cKDTree
/usr/lib64/python3.10/site-packages/scipy/spatial/__init__.py:97: in <module>
    from .ckdtree import *
ckdtree.pyx:1: in init scipy.spatial.ckdtree
    ???
E   RuntimeWarning: builtins.type size changed, may indicate binary incompatibility. Expected 880 from C header, got 888 from PyObject
```

Some other errors may be due to numpy-1.20.0rc2, reported upstream https://gitlab.com/ase/ase/-/issues/827

Comment 3 Tomáš Hrnčiar 2021-01-08 08:07:47 UTC
I don't think that failure is Python 3.10 specific. PYTHON3.10 blocker is here just for our tracking purposes.
Koschei says it fails in rawhide which uses Python 3.9.

To reproduce it you can run:
koji build --scratch f34 python-ase-3.19.1-4.fc33.src.rpm

==============================================================================
Error in preconsmallcell.py on pid 3576003:
Workdir: /tmp/ase-test-kvxb5xal/preconsmallcell_py
Traceback (most recent call last):
  File "/builddir/build/BUILD/ase-3.19.1/build/lib/ase/test/testsuite.py", line 128, in run_single_test
    runtest_almost_no_magic(filename)
  File "/builddir/build/BUILD/ase-3.19.1/build/lib/ase/test/testsuite.py", line 74, in runtest_almost_no_magic
    runpy.run_path(path, run_name='test')
  File "/usr/lib64/python3.9/runpy.py", line 268, in run_path
    return _run_module_code(code, init_globals, run_name,
  File "/usr/lib64/python3.9/runpy.py", line 97, in _run_module_code
    _run_code(code, mod_globals, init_globals,
  File "/usr/lib64/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/builddir/build/BUILD/ase-3.19.1/build/lib/ase/test/preconsmallcell.py", line 36, in <module>
    assert len(w) == 0
AssertionError
==============================================================================

Failures and errors:
preconsmallcell.py: AssertionError: 
========== Summary ==========
Number of tests   363
Passes:           251
Failures:           1
Errors:             0
Skipped:          111
=============================
Test suite failed!
Time elapsed: 137.7 s
error: Bad exit status from /var/tmp/rpm-tmp.iyqTY0 (%check)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.iyqTY0 (%check)
Child return code was: 1
EXCEPTION: [Error()]
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/mockbuild/trace_decorator.py", line 93, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.9/site-packages/mockbuild/util.py", line 789, in do_with_status
    raise exception.Error("Command failed: \n # %s\n%s" % (command, output), child.returncode)
mockbuild.exception.Error: Command failed: 
 # bash --login -c /usr/bin/rpmbuild -bb --target noarch --nodeps /builddir/build/SPECS/python-ase.spec

Comment 4 marcindulak 2021-01-08 10:43:50 UTC
Another, more specific upstream issue https://gitlab.com/ase/ase/-/issues/828

Comment 5 Fedora Release Engineering 2021-01-24 04:22:30 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-04).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 6 marcindulak 2021-01-25 20:37:46 UTC
Fixed by removing the failing test https://koji.fedoraproject.org/koji/taskinfo?taskID=60485410


Note You need to log in before you can comment on or make changes to this bug.