Bug 1913785 - Failed to add host with error Format specifier '%2b'
Summary: Failed to add host with error Format specifier '%2b'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.4.4.7
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.4.7
: ---
Assignee: Dana
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-07 15:44 UTC by Petr Matyáš
Modified: 2021-07-28 14:16 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-4.4.7.6
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-28 14:16:37 UTC
oVirt Team: Infra
pm-rhel: ovirt-4.4+
michal.skrivanek: blocker-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 115428 0 master MERGED ansible: use String.format() only when there are actual params 2021-06-29 11:29:29 UTC

Description Petr Matyáš 2021-01-07 15:44:21 UTC
Description of problem:
There are not many details but whenever I try to install additional hosts to my clean new installed HE setup all of that is failing on:
2021-01-07 17:18:25,781+02 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (EE-ManagedThreadFactory-engine-Thread-110) [140ff1fd-9017-434e-a9ed-36c5b729839e] EVENT_ID: VDS_INSTALL_FAILED(505), Host host_mixed_3 installation failed. Format specifier '%2b'.

Version-Release number of selected component (if applicable):
ovirt-engine-4.4.4.7-0.1.el8ev.noarch

How reproducible:
always

Steps to Reproduce:
1. install HE
2. add additional host
3.

Actual results:
fail with format specifier error

Expected results:
host is added successfully

Additional info:

Comment 2 Yedidyah Bar David 2021-01-10 10:14:51 UTC
Does this reproduce?

Please attach also host-deploy logs.

Comment 3 Lukas Svaty 2021-01-11 09:01:52 UTC
I checked the host deploy, engine logs, ansible logs, there is nothing other than the error Format specifier '%2b'.
After reinstall the host activated successfully, I believe Petr have an env still with 1 more host broken this way, but reinstalling the host would put it to successful active state.

Comment 4 Yedidyah Bar David 2021-01-11 10:02:43 UTC
(In reply to Lukas Svaty from comment #3)
> I checked the host deploy, engine logs, ansible logs, there is nothing other
> than the error Format specifier '%2b'.
> After reinstall the host activated successfully, I believe Petr have an env
> still with 1 more host broken this way, but reinstalling the host would put
> it to successful active state.

If it's not reproducible, please CLOSE WORKSFORME. Otherwise, please attach logs. Thanks!

Comment 5 Petr Matyáš 2021-01-11 11:10:45 UTC
Environment was destroyed (reprovisioned) by mistake on my part and as this does not reproduce on this env or any other, closing and hope to not see it in the future.

Comment 6 Evelina Shames 2021-06-23 09:28:08 UTC
Reopening this bug as I think I hit the issue:

2021-06-22 18:28:33,559+03 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (EE-ManagedThreadFactory-engine-Thread-31) [7bdf6bd3] EVENT_ID: VDS_INSTALL_FAILED(505), Host host_mixed_3 installation failed. Format specifier '%2b'.

Attaching engine log.

Petr, can you pls check if this is indeed the same issue?

Comment 8 Petr Kubica 2021-06-23 10:28:50 UTC
Error is actually from ansible runner
msg is not propagated to events (audit log): 'msg': 'Failed to download packages: Cannot download Packages/qemu-kvm-block-curl-5.2.0-16.module

2021-06-22 18:28:30,735 - runner_service.services.playbook - DEBUG - cb_event_handler event_data={'uuid': '0346ca66-fbea-41cc-81a0-f987774eca80', 'counter': 59, 'stdout': 'fatal: [host]: FAILED! => {"changed": false, "msg": "Failed to download packages: Cannot download Packages/qemu-kvm-block-curl-5.2.0-16.module%2bel8.4.0%2b10806%2bb7d97207.x86_64.rpm: All mirrors were tried", "results": []}', 'start_line': 51, 'end_line': 52, 'runner_ident': '62aec6bc-d36e-11eb-8837-001a4a168f00', 'event': 'runner_on_failed', 'p
id': 9947, 'created': '2021-06-22T15:28:30.733731', 'parent_uuid': '001a4a16-8f00-80e0-2c51-0000000001a9', 'event_data': {'playbook': 'ovirt-host-deploy.yml', 'playbook_uuid': 'afc2bc81-d5fc-474a-9632-f436f61d7e4a', 'play': 'all', 'play_uuid': '001a4a16-8f00-80e0-2c51-00000
0000008', 'play_pattern': 'all', 'task': 'Install ovirt-hosted-engine-setup package', 'task_uuid': '001a4a16-8f00-80e0-2c51-0000000001a9', 'task_action': 'yum', 'task_args': '', 'task_path': '/usr/share/ovirt-engine/ansible-runner-service-project/project/roles/ovirt-host-de
ploy-vdsm/tasks/packages.yml:6', 'role': 'ovirt-host-deploy-vdsm', 'host': 'host', 'remote_addr': 'host', 'res': {'msg': 'Failed to download packages: Cannot download Packages/qemu-kvm-block-curl-5.2.0-16.module%2bel
8.4.0%2b10806%2bb7d97207.x86_64.rpm: All mirrors were tried', 'results': [], 'invocation': {'module_args': {'name': ['ovirt-hosted-engine-setup'], 'state': 'present', 'allow_downgrade': False, 'autoremove': False, 'bugfix': False, 'disable_gpg_check': False, 'disable_plugin
': [], 'disablerepo': [], 'download_only': False, 'enable_plugin': [], 'enablerepo': [], 'exclude': [], 'installroot': '/', 'install_repoquery': True, 'install_weak_deps': True, 'security': False, 'skip_broken': False, 'update_cache': False, 'update_only': False, 'validate_
certs': True, 'lock_timeout': 30, 'conf_file': None, 'disable_excludes': None, 'download_dir': None, 'list': None, 'releasever': None}}, '_ansible_no_log': False, 'changed': False}, 'start': '2021-06-22T15:27:52.264033', 'end': '2021-06-22T15:28:30.733528', 'duration': 38.4
69495, 'ignore_errors': None, 'event_loop': None, 'uuid': '0346ca66-fbea-41cc-81a0-f987774eca80'}}
2021-06-22 18:28:30,736 - runner_service.services.playbook - DEBUG - cb_event_handler event_data={'uuid': '4790bd1c-d454-4954-9a83-108b599fd62d', 'counter': 60, 'stdout': '\r\nPLAY RECAP *********************************************************************\r\nhost
 : ok=17   changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   \r\n', 'start_line': 52, 'end_line': 56, 'runner_ident': '62aec6bc-d36e-11eb-8837-001a4a168f00', 'event': 'playbook_on_stats', 'pid': 9947, 'created': '2021-06-22T1
5:28:30.736082', 'parent_uuid': 'afc2bc81-d5fc-474a-9632-f436f61d7e4a', 'event_data': {'playbook': 'ovirt-host-deploy.yml', 'playbook_uuid': 'afc2bc81-d5fc-474a-9632-f436f61d7e4a', 'changed': {'host': 3}, 'dark': {}, 'failures': {'host
': 1}, 'ignored': {}, 'ok': {'host': 17}, 'processed': {'host': 1}, 'rescued': {}, 'skipped': {}, 'artifact_data': {}, 'uuid': '4790bd1c-d454-4954-9a83-108b599fd62d'}}
2021-06-22 18:28:30,929 - runner_service.services.playbook - INFO - Playbook ovirt-host-deploy.yml, UUID=62aec6bc-d36e-11eb-8837-001a4a168f00 ended, status=failed
2021-06-22 18:28:30,934 - runner_service.services.playbook - INFO - Playbook ovirt-host-deploy.yml Stats: {'skipped': {}, 'ok': {'host': 17}, 'dark': {}, 'failures': {'host': 1}, 'processed': {'host': 1}, 'changed': {'host': 3}}

Comment 9 Martin Perina 2021-06-23 11:15:40 UTC
It happens only very rarely, decreasing medium

Comment 10 Petr Kubica 2021-06-23 11:23:23 UTC
just for the information
ansible host deploy log ends with:

....
      "start" : "2021-06-22T15:27:52.027776",
      "end" : "2021-06-22T15:27:52.099039",
      "duration" : 0.071263,
      "event_loop" : "items",
      "uuid" : "1ab2914a-bf0e-4a09-a32e-416cfc3e9764"
    }
  }
}

2021-06-22 18:27:54 IDT - TASK [ovirt-host-deploy-vdsm : Install ovirt-hosted-engine-setup package] ******
<EOF>

Comment 15 Dana 2021-06-27 09:59:49 UTC
I fixed the format specifier error message, but note, as stated in https://bugzilla.redhat.com/show_bug.cgi?id=1913785#c8, the real issue is about a package that couldn't be downloaded: 
"msg": "Failed to download packages: Cannot download Packages/qemu-kvm-block-curl-5.2.0-16.module%2bel8.4.0%2b10806%2bb7d97207.x86_64.rpm: All mirrors were tried",

Comment 16 RHEL Program Management 2021-06-28 07:09:20 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 18 Petr Matyáš 2021-07-12 12:19:07 UTC
Verified on ovirt-engine-4.4.7.6-0.11.el8ev.noarch

Comment 19 Sandro Bonazzola 2021-07-28 14:16:37 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.