Bug 1913789 - [RFE] Add RHEL 9 as a guest operating systems
Summary: [RFE] Add RHEL 9 as a guest operating systems
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.4.7
: 4.4.7
Assignee: Liran Rotenberg
QA Contact: Tamir
URL:
Whiteboard:
: 1941324 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-07 15:52 UTC by Michal Skrivanek
Modified: 2021-07-08 14:15 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.4.7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-08 14:15:44 UTC
oVirt Team: Virt
ahadas: ovirt-4.4?
pm-rhel: planning_ack?
ahadas: devel_ack+
pm-rhel: testing_ack+


Attachments (Terms of Use)
Screenshot from 2021-06-17 02-22-14.png (127.98 KB, image/png)
2021-06-16 23:22 UTC, Nikolai Sednev
no flags Details
Screenshot from 2021-06-17 02-23-40.png (64.54 KB, image/png)
2021-06-16 23:23 UTC, Nikolai Sednev
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 114569 0 master MERGED osinfo: add rhel9 guests 2021-05-06 08:18:13 UTC

Description Michal Skrivanek 2021-01-07 15:52:36 UTC
Let's add support for running a RHEL 9 guest
- new OS type and drop down
- icon
- make sure qemu-ga works ok
- especially check of QXL/SPICE console since SPICE is dropped from RHEL 9 )our RHEL8 host will have spice-server, but guest may not have qxl)

Comment 1 Arik 2021-03-22 12:04:54 UTC
From bz 1941324:
Configure, by default, RHEL-9 Desktop/Workstation VMs with virtio-vga (and virtio-gpu) devices.

Comment 2 Arik 2021-03-22 12:05:29 UTC
*** Bug 1941324 has been marked as a duplicate of this bug. ***

Comment 4 Nikolai Sednev 2021-06-16 23:22:58 UTC
Created attachment 1791628 [details]
Screenshot from 2021-06-17 02-22-14.png

Comment 5 Nikolai Sednev 2021-06-16 23:23:59 UTC
Created attachment 1791629 [details]
Screenshot from 2021-06-17 02-23-40.png

Comment 6 Nikolai Sednev 2021-06-16 23:25:26 UTC
- new OS type and drop down - Added OK
- icon - Added OK
Tested on ovirt-engine-setup-4.4.7.3-0.3.el8ev.noarch

Comment 7 Tamir 2021-06-20 15:27:35 UTC
Verified on RHV 4.4.7-3. All looks good to me.

Env:
  - Engine instance with RHV 4.4.7-3 (ovirt-engine-4.4.7.3-0.3.el8ev) and RHEL 8.4 installed.
  - 3 hosts with RHV 4.4.7-3 and RHEL 8.4, vdsm-4.40.70.3-1.el8ev


Tests:

  - Ran the RHEL based guest image regression on the latest RHEL 9 image with UEFI and BIOS.
    
    Result: All the tests passed.


  - Checked that QEMU information was retrieved from the VM and it is displayed properly.
    
    Result: The QEMU information was retrieved from the VM and it is displayed properly.


  - Checked that RHEL 9 is listed as an operating systems (Checked Rest and UI).

    Result: It appeared in the dropdown when creating/editing VM/Templates and also in the Rest API:
      
        <name>rhel_9x64</name>
        <description>Red Hat Enterprise Linux 9.x x64</description>
        <architecture>x86_64</architecture>

        <name>rhel_9_ppc64</name>
        <description>Red Hat Enterprise Linux 9.x</description>
        <architecture>ppc64</architecture>
   

  - Checked that the icon for RHEL 9 is set with RHEL's icon.
    
    Result: The OS icon is set and it is RHEL's icon.

Comment 12 Sandro Bonazzola 2021-07-08 14:15:44 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.